When fullscreening a video while the dynamic toolbar is showing, the toolbar area shows garbage

RESOLVED FIXED in Firefox 43

Status

()

Firefox for Android
Toolbar
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

unspecified
Firefox 43
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment)

Using the test case from bug 1196172, if you fullscreen the video while the toolbar is visible the top area of the screen shows garbage/underlying content. This is in addition to the content that is visible as part of that bug. The hit-testing also seems to be a bit off in that while fullscreened in this state taps on the scrubber and controller buttons are offset. All of this is a regression from the new dynamic toolbar and so I want to track it separately from bug 1196172, and fix this before I tackle that.
Created attachment 8651111 [details] [diff] [review]
Patch

The main problem was that DynamicToolbarAnimator.getViewportSize was getting called around the start of the animation so mToolbarTranslation was not what the final value would have been at the end of the animation.
Attachment #8651111 - Flags: review?(rbarker)
Attachment #8651111 - Flags: review?(rbarker) → review+
https://hg.mozilla.org/mozilla-central/rev/0d8e63323117
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Blocks: 998929
Blocks: 1115003
You need to log in before you can comment on or make changes to this bug.