[Wifi] Server certificate items are duplicated when disabling and re-enabling wifi

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gchang, Assigned: iliu)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 affected, b2g-v2.0 verified, b2g-v2.1 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
### Steps:
1. Import 2 server certificates from Settings > Wi-Fi > Manage certificates
2. Close Settings app
3. Open Settings > Wi-Fi page
4. Select a EAP WLAN, EAP method is TTLS
5. Tap "Server certficate"
6. There are 2 certificates listed here, which is expected
7. Click "<" to go back to previous page and disable Wi-Fi
8. Enable Wi-Fi again
9. Select a EAP WLAN again
10. Tap "Server certficate" again
11. One of the certificates is duplicated

### Expected:
There should be no certificates duplicated here.

### Actual:
One certificate is duplicated.

### Reproduce rate
always

### Version:
Device    flame
Gaia      43226cf5c3ad19728a88b3786595670b6d60e5c6
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/d0275ba5f438
BuildID   20140701160202
Version   32.0a2
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?
(Assignee)

Updated

4 years ago
See Also: → bug 1031217

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Ian, could you help?
Flags: needinfo?(iliu)
Yes, take over the issue.
Assignee: nobody → iliu
Flags: needinfo?(iliu)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Created attachment 8451509 [details] [review]
pull request 21438

Arthur, could you please help to review my pull request? Thanks.
Attachment #8451509 - Flags: review?(arthur.chen)
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.0 S6 (18july)
Comment on attachment 8451509 [details] [review]
pull request 21438

r=me, thank you.
Attachment #8451509 - Flags: review?(arthur.chen) → review+
Just rebase the patch for verification test again.
Since the pr is landed, we can close the issue now.

Gaia/master:  e970c7e69c213fd896383b0dc7b85a1b7b1d7dc8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.3: --- → affected
status-b2g-v1.3T: --- → affected
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Gaia/v2.0:  35a9b715e7348ec738ff6c8a59f50190390a06f2
status-b2g-v2.0: affected → fixed
FYI, checkin-needed means "please help me land this" which clearly wasn't the case here.
Keywords: checkin-needed
(Reporter)

Comment 9

4 years ago
Verified @
Gaia      ca022f811bcbbda0f89086094a9e92bb220fea18
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/376889ab0e02
BuildID   20140713160202
Version   32.0a2
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
Hi Reporter,
    Could you provide the certificates for me to verify this bug on flame v2.1?

Thank you!
Flags: needinfo?(gchang)
(Reporter)

Comment 11

4 years ago
Created attachment 8533479 [details]
A server certificate.
Flags: needinfo?(gchang)
(Reporter)

Comment 12

4 years ago
Created attachment 8533480 [details]
Another server certificate.
Per Comment 9,set Flame v2.0 as "verified".

-------------------------------------------------
This bug has been failed verified on latest Flame v2.1 (Rate:5/5,see "verified_v2.1.mp4"). 
I will submit a following up bug tomorrow.

Repro STR:
1. Copy the two server certificate to device's storage.
2. Open "Settings"->"Manage certificates"->"Import certificate",then import the certificates.
3. Select a EAP WLAN, EAP method is TTLS.
4. Tap "Server certficate".
5. There are 2 certificates listed here.
6. Tap "Ok" and tap "<" to go back to Wi-fi list.
8. Select the EAP WLAN again.
9. Tap "Server certficate" again.
**One certificate is duplicated. --KO
status-b2g-v2.0: fixed → verified
The following up bug is bug 1145031.
Hi Mike,
   
    This bug has been failed verified on latest Flame v2.1 in Comment 13,and I had filed a following up bug. Could you help with the following up bug (1145031)?

Thank you very much.
Flags: needinfo?(mlien)

Comment 17

4 years ago
Already ni developer from the following bug, keep tracking
Flags: needinfo?(mlien)
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.