Closed Bug 1145031 Opened 7 years ago Closed 7 years ago

[Flame][Wifi] Server certificate items are duplicated when user re-open "Server certficate" of the WLAN with EAP and TTLS.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.1S --- verified
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: lixia, Assigned: iliu)

References

Details

(Keywords: regression)

Attachments

(7 files)

[1.Description]:
According to Bug 1033183 in Comment 13, this bug is filed.
[Flame][v2.1S][v2.1&2.2&3.0][Wifi]Re-open the WLAN with EAP and TTLS,then tap on "Server certficate" icon,server certificate items are duplicated.
Found time:11:04
Attach:wifi_certficates.mp4 and logcat_1104.txt.
Test certficates:cacert.crt and gogogo.crt.

[2.Testing Steps]: 
1. Copy two server certificates to device.
2. Open "Settings"->"Manage certificates"->"Import certificate",and import the certificates.
3. Back to wifi list, then tap a EAP WLAN and select "TTLS".
4. Tap on "Server certficate".
** Two certificates lists.
5. Tap "Ok" and tap "<" to back to Wifi list.
6. Repeat step 3 and step 4.

[3.Expected Result]: 
6.It should only list two certificates.

[4.Actual Result]: 
6.There are three certificates listed, and one certificate is duplicated.

[5.Reproduction build]: 
Flame 2.0 (unaffected):
Build ID               20150318000203
Gaia Revision          896803174633fc6acd3fd105f81c349b8e9b9633
Gaia Date              2015-03-10 06:32:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/3db01d6d6df5
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.035405
Firmware Date          Wed Mar 18 03:54:15 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1 (affected):
Build ID               20150318001207
Gaia Revision          13c85d57f49b4bfd657ff674f2b530c141c94803
Gaia Date              2015-03-17 13:31:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/2fbd284621e2
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040035
Firmware Date          Wed Mar 18 04:00:46 EDT 2015
Bootloader             L1TC000118D0

Flame 2.2 (affected):
Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (affected):
Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.093634
Firmware Date          Wed Mar 18 09:36:44 EDT 2015
Bootloader             L1TC000118D0

2.1S_512mb (affected):
Build ID               20150318161205
Gaia Revision          13c85d57f49b4bfd657ff674f2b530c141c94803
Gaia Date              2015-03-17 13:31:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/e64b1776894a
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
See Also: → 1033183
Attached file logcat_1104.txt
Attached file cacert.crt
Attached file gogogo.crt
Hi Ian, this is a folloing bug from bug 1033183 and I find you mentioned this issue should be fixed on bug 1033183 comment 6.
Could you help with this issue again, thanks.
Flags: needinfo?(iliu)
Comment on attachment 8583660 [details] [review]
[gaia] ian-liu:wifi/bug1145031_fix_duplicated_option_in_server_certificate_select_options > mozilla-b2g:master

Ej, the problem is fixed before Settings:Wifi has not been refactored(v2.0)(bug 1033183 comment 6). I guess the fixing patch of bug 1033183 comment 6 is missed to update on Gaia/master. I create a new patch to fix it again for the new code base. Could you please help to review it? Thanks.
Flags: needinfo?(iliu)
Attachment #8583660 - Flags: review?(ejchen)
Comment on attachment 8583660 [details] [review]
[gaia] ian-liu:wifi/bug1145031_fix_duplicated_option_in_server_certificate_select_options > mozilla-b2g:master

Thanks Ian, r+ :)
Attachment #8583660 - Flags: review?(ejchen) → review+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This bug has been successfully verified on latest Nightly Flame v3.0. It only shows two certificates in "Server certficate" list as expected.
See attachment: verified_v3.0.MP4
Reproduce rate: 0/5


Device: Flame 3.0 build(Pass)
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.193255
Firmware Date          Thu Apr  9 19:33:06 EDT 2015
Bootloader             L1TC000118D0

Leaving "verifyme" keywords for branch uplift.
Keywords: verifyme
Attached video verified_v3.0.mp4
QA Whiteboard: [MGSEI-Triage+]
Hi Lan,

This bug has been fixed on Master, but not on Flame v2.2/2.1/2.1S, will it land on these branches? thanks.
Flags: needinfo?(iliu)
Norry,

Thanks for your reminder here. Per comment 7, bug 1033183 comment 6 fixed the problem for v2.0/v2.1. At the time, we also have another patch to refactor Settings::Wifi(bug 973466). The the patch did not contain bug 1033183. So that the problem is re-open with bug 973466.

Since bug 973466 is landed in Gaia/master/v2.2/v2.1, we have to uplift bug 1145031 here we do for these branches.
Flags: needinfo?(iliu)
Comment on attachment 8583660 [details] [review]
[gaia] ian-liu:wifi/bug1145031_fix_duplicated_option_in_server_certificate_select_options > mozilla-b2g:master

Per comment 13,

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):regressing bug 973466
[User impact] if declined: A user will see duplicated certificates.
[Testing completed]: Unit test passed
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8583660 - Flags: approval-gaia-v2.2?
Attachment #8583660 - Flags: approval-gaia-v2.1?
This is a regression which we blocked in 2.0 and the issue was never fixed in follow-up branches (2.1/2.2..), so approving this now, but requesting qa verification here once this lands on the branches.
blocking-b2g: --- → 2.1+
Keywords: regression
Attachment #8583660 - Flags: approval-gaia-v2.2?
Attachment #8583660 - Flags: approval-gaia-v2.2+
Attachment #8583660 - Flags: approval-gaia-v2.1?
Attachment #8583660 - Flags: approval-gaia-v2.1+
This bug has been verified as pass on latest Nightly build of Flame v2.1 by the STR in Comment 0.

Actual results: Server certificate items will not be duplicated anymore.
See attachment: verified_v2.1.mp4
Reproduce rate: 0/5


Device: Flame 2.1 build(Pass)
Build ID               20150507161202
Gaia Revision          3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gaia Date              2015-05-07 15:12:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d85173eb5bf4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.194632
Firmware Date          Thu May  7 19:46:42 EDT 2015
Bootloader             L1TC000118D0
Attached video verified_v2.1.mp4
This bug has been verified as pass on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: Server certificate items will not be duplicated anymore.
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.042512
Firmware Date          Sun May 10 04:25:23 EDT 2015
Bootloader             L1TC000118D0

-------------------------------------------------------------
Leaving "verifyme" for v2.1S uplift & verification.
This bug has been verified as pass on latest Nightly build of v2.1S(512mb) by the STR in Comment 0.

Actual results: Server certificate items will not be duplicated anymore.
See above attachment:verified_v2.1.mp4.
Reproduce rate: 0/5

Device: v2.1S_512mb (Pass)
Build ID               20150519001205
Gaia Revision          0d02a2b2ff3afd391809cf6ad273bd5919ced9a0
Gaia Date              2015-05-19 02:01:05
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/b69eec9a3737
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.