[MSISDN Authentication][System] International prefix duplicated

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mbarone976, Assigned: willyaranda)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: ft:loop)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8449341 [details]
device-2014-07-02-122558.png

STR

Pre-Condition: Device without SIM

1. Open Loop app and register into the app using the option "Phone Number"
2. In the drop-down list for the international prefix select the prefix.

ACTUAL RESULT
In the drop down list many prefix are duplicated (i.e. +1, or +44, etc). See attachment

EXPECTED RESULT
The list should not contain duplicated fields.
Component: Gaia::System → Gaia::Loop
If this is a Loop-specific bug, then this shouldn't block, given that's not requiring core build changes. We should figure another way to track the work required here though to deploy the mobile client on marketplace.
(In reply to Jason Smith [:jsmith] from comment #1)
> If this is a Loop-specific bug, then this shouldn't block, given that's not
> requiring core build changes. We should figure another way to track the work
> required here though to deploy the mobile client on marketplace.

This is not related with Loop, it's related with MSISDN Authentication flow.

It's true that several MCC are related with the same 'Country Code', so it would be great to show the name of the 'Region' instead of the Country Code, in order to choose the right one. Renaming & assigning to me! Thanks!
Component: Gaia::Loop → Gaia::System
Summary: Loop: International prefix duplicated → [MSISDN Authentication][System] International prefix duplicated
Assignee: nobody → borja.bugzilla
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Blocks: 1021594
Whiteboard: ft:loop
Is the international prefix drop-down a system wide feature?

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Any updates here? This needs to get in by next week or it won't be in 2.0
Flags: needinfo?(borja.bugzilla)
Assignee: borja.bugzilla → willyaranda
Guillermo is going to take a look to this bug. Thanks!
Flags: needinfo?(borja.bugzilla)
Attachment #8454398 - Flags: review?(ferjmoreno)
Comment on attachment 8454398 [details] [review]
Patch

Thanks Guillermo!
Attachment #8454398 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/b422bc5f15c18fd4c683d2eddc72d659abc490cf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S6 (18july)

Comment 10

4 years ago
Verified the issue is fixed on 2.0 and 2.1

No duplicated International prefix appears on the drop off menu in "Loop" app

"Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141118000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 2bea026d4f86
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141118001204
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.