Credentials from voyages-sncf.mobi lost after device reboot (B2G) or Browser restarted (Firefox for Android)

RESOLVED WONTFIX

Status

Tech Evangelism
Mobile
P5
normal
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-fr] [sitewait], URL)

(Reporter)

Description

4 years ago
STR:
 0. Connect on voyages-sncf.mobi installed as a bookmark
 1. Reboot device

Expected:
 When I reopen the bookmark, my session is kept

Actual:
 I have to relogin
(Reporter)

Updated

4 years ago
Blocks: 949551
(Reporter)

Comment 1

4 years ago
Can also be triggered by a stop b2g && start b2g.
Summary: Bookmarks credentials lost after device reboot → Bookmarks credentials lost after device reboot or b2g stop/start
(Reporter)

Comment 2

4 years ago
This is also affecting the OVH hubic application.
Summary: Bookmarks credentials lost after device reboot or b2g stop/start → Credentials lost after device reboot or b2g stop/start
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877648
After talking to Alexandre, reopening for investigation.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Flags: needinfo?(nhirata.bugzilla)
I am amused by the website that you have to select other languages for english.

I used facebook, bugzilla, gmail, yahoo mail, and cnn and they were still signed in there just fine.


If this is still occurring, I think it's the web pages.  I'm not exactly sure how to sign into voyages-sncf.mobi and I'm not sure what OVH hubic is.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(lissyx+mozillians)
If this is still occurring, please change to tech evang if you concur.
(Reporter)

Comment 7

3 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> I am amused by the website that you have to select other languages for
> english.
> 
> I used facebook, bugzilla, gmail, yahoo mail, and cnn and they were still
> signed in there just fine.
> 
> 
> If this is still occurring, I think it's the web pages.  I'm not exactly
> sure how to sign into voyages-sncf.mobi and I'm not sure what OVH hubic is.

Voyages SNCF is the website I use to buy my train tickets for commuting :). OVH Hubic is a storage service, similar to Google Drive/Dropbox.

I'll recheck.
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 8

3 years ago
Naoki, I'm not convinced it's only due to the website itself.

STR:
 0. Navigate to https://voyages-sncf.mobi, with the useragent override:
> user_pref("general.useragent.override.voyages-sncf.mobi", "Mozilla/5.0 (Android; Mobile; rv:38.0) Gecko/38.0 Firefox/38.0");
 1. Refuse the Android app :)
 2. You should be presented a banner about Cookies, accept
 3. Login, and check the "remember me" checkbox
 4. Reboot the device, navigate again

Expected:
 I am still logged in

Actual:
 I'm logged out, and I get the cookie banner again.
(Reporter)

Comment 9

3 years ago
Yet, after checking on Android with Firefox Nightly, I do reproduce the exact same behavior: killing the browser makes me logged out :(
(Reporter)

Comment 10

3 years ago
And that's the same on Firefox for Android stable :(
(Reporter)

Comment 11

3 years ago
Same with Firefox Nightly on my desktop, with or without the user agent override.
(Reporter)

Updated

3 years ago
Component: Gaia::System → Mobile
Product: Firefox OS → Tech Evangelism
(Reporter)

Updated

3 years ago
Summary: Credentials lost after device reboot or b2g stop/start → Credentials from voyages-sncf.mobi lost after device reboot (B2G) or Browser restarted (Firefox for Android)
(Reporter)

Updated

3 years ago
Depends on: 964532
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1136691
(Reporter)

Comment 13

3 years ago
Karl, can you help me ?
Flags: needinfo?(kdubost)
Alexandre,

Did you use a clean profile?

Do you observe differences in cookies in between Firefox and another browser?
see http://www.otsukare.info/2014/11/12/configure-webcompat-browser
If there's a difference in cookies, is it visible which one?
Is the same happening on other browsers?
Flags: needinfo?(kdubost) → needinfo?(lissyx+mozillians)
(Reporter)

Comment 15

3 years ago
(In reply to Karl Dubost :karlcow from comment #14)
> Alexandre,
> 
> Did you use a clean profile?

Yes.

> 
> Do you observe differences in cookies in between Firefox and another browser?
> see http://www.otsukare.info/2014/11/12/configure-webcompat-browser
> If there's a difference in cookies, is it visible which one?

I'm going to check, but the "remember_me" cookie is properly set.

> Is the same happening on other browsers?
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 16

3 years ago
Tested in Chromium and I have the same behavior. BTW in the meantime I've contacted the website support and explained them my issue, I hope they will get back to me soon.
(Reporter)

Comment 17

3 years ago
I got a reply from support, they are transferring this to technical people.
Flags: needinfo?(kdubost)
(Reporter)

Comment 18

3 years ago
Investigating HubiC issues, I found both expose the same behavior: session ID cookie is send with an epoch expire:

> name: JSESSIONID                                         
> value: xxxx.bk-vsc-tgv-3     
> host: voyages-sncf.mobi                                  
> path: /                                                  
> expires: Wed Dec 31 23:59:59 1969 GMT (at end of session)
> created: Wed Apr 08 12:15:58 2015 GMT                    
> is secure: false                                         
> is httpOnly: false   

So, B2G restarting probably triggers the "end of session".
(In reply to Alexandre LISSY :gerard-majax from comment #17)
> I got a reply from support, they are transferring this to technical people.

Wonderful! Thanks.
Flags: needinfo?(kdubost)
Whiteboard: [country-fr] [sitewait]
(Reporter)

Comment 20

3 years ago
Karl, I got a new reply from the support, in french:

> Nous regrettons ce délai exceptionnel de traitement de votre demande.
> 
> Soucieux de répondre au mieux à vos attentes, vos remarques ont été remontées à nos équipes techniques.
> 
> Cette anomalie a été identifiée et sera corrigée très prochainement.
> 
> Vous présentant nos excuses pour la gêne occasionnée.
> 
> Cordialement. 

So for non french readers, it means they have identified the issue and it will be fixed soon. Thanks to anyone from this team that may be reading this bug :)
Flags: needinfo?(kdubost)
Very cool Alexandre.
Flags: needinfo?(kdubost)
(Reporter)

Updated

3 years ago
Keywords: dogfood → foxfood
(Reporter)

Comment 22

3 years ago
Four months after. Still not working on B2G.
(Reporter)

Comment 23

3 years ago
Still nothing.
(Reporter)

Comment 24

3 years ago
Jean, I think we should seriously work on session restoring on B2G: this is the kind of issues that crippled a foxfood experience.
Flags: needinfo?(jgong)
(Reporter)

Comment 25

3 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #24)
> Jean, I think we should seriously work on session restoring on B2G: this is
> the kind of issues that crippled a foxfood experience.

On Firefox Nightly for Android, this is mitigated because we have the password manager kicking in.
(Reporter)

Comment 26

3 years ago
I guess password manager would be easier?
(Reporter)

Comment 27

3 years ago
Looks like we loose the session after a few hours:

 - login
 - display tickets list
 - wait a few hours (one? two? At least )
 - go back on home page of website

Expected: still logged in
Actual: disconnected
(Reporter)

Updated

3 years ago
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

Updated

2 years ago
Priority: -- → P5
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

2 years ago
Flags: needinfo?(jgong)
You need to log in before you can comment on or make changes to this bug.