Closed Bug 1033451 Opened 6 years ago Closed 6 years ago

[Smart Collection] Adding collection to top is slow to draw and load

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect, P1, blocker)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: tchung, Assigned: kgrandon)

References

Details

(Keywords: perf, Whiteboard: [c=handeye p= s=2014.07.18.t u=2.0] [2.0-VH-bug-bash][systemsfe])

Attachments

(2 files)

See screenshot.   when trying to long tap and move a smart collection to the top of your collections, the screen is slow to redraw, icons dissapear and reappear, and the perceived performance is overall laggy. 

See screencast: http://youtu.be/t-PRY3pYodU

1) install 2.0 build on flame

Gaia      3bfe47c58c959c42f5ffe0309b5380ea514ccd69
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f40e767ea283
BuildID   20140702000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

2) on homescreen, long tap and add a smart collection  (ie. custom -- "porsche")
3) open that collection, and scroll down, and long tap on any of the collection
4) click "Add to Top of collection"
5) Verify it is slow to add, with icons disappearing for a second, and laggy loading. 

Expected:
- moving the smart collection site to the top should feel faster, comparing to a baseline of how we move apps on the homescreen

Actual:
- performance is slower
Priority: -- → P3
Whiteboard: [2.0-VH-bug-bash] → [2.0-VH-bug-bash][c=handeye p= s= u=]
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Component: Gaia::Homescreen → Gaia::Everything.me
Blocks: 1015336
Whiteboard: [2.0-VH-bug-bash][c=handeye p= s= u=] → [2.0-VH-bug-bash][c=handeye p= s= u=][systemsfe]
Definitely looks ugly. UX - Is this a blocker from your perspective?
Flags: needinfo?(firefoxos-ux-bugzilla)
Unfortunately, since it involves homescreen, I think we have to block on this one. I saw this at varying levels yesterday during the bug bash: sometimes it was very slow, sometimes barely noticeable. But I think we have to block. Sorry!
Flags: needinfo?(firefoxos-ux-bugzilla)
Attached file Github pull request
blocking-b2g: 2.0? → 2.0+
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
Severity: normal → blocker
Priority: P3 → P1
Whiteboard: [2.0-VH-bug-bash][c=handeye p= s= u=][systemsfe] → [c=handeye p= s= u=2.0] [2.0-VH-bug-bash][systemsfe]
Duplicate of this bug: 1033500
Comment on attachment 8450654 [details] [review]
Github pull request

Hey Cristian - could you review these performance improvements to smart collections while the E.me guys are on PTO? Thanks!
Attachment #8450654 - Flags: review?(crdlc)
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S5 (4july)
Comment on attachment 8450654 [details] [review]
Github pull request

Amazing good job! I tested it on my device and it is very fast now!! Ans I didn't  find any regression. Thanks a lot
Attachment #8450654 - Flags: review?(crdlc) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/bff35131b7eba7b4d05536313b99f82915423a39
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: 2.0 S5 (4july) → 2.0 S6 (18july)
Whiteboard: [c=handeye p= s= u=2.0] [2.0-VH-bug-bash][systemsfe] → [c=handeye p= s=2014.07.18.t u=2.0] [2.0-VH-bug-bash][systemsfe]
This issue has been successfully verified on Flame v2.1&2.0.
See attachment: verified_v2.1.mp4
Reproduce rate: 0/5

STR:
1. On homescreen, long tap and add a smart collection  (ie. custom -- "porsche")
2. Open the collection, and scroll down, and long tap on any of the collection.
4. Click "Add to Top of collection".
5. Verify it is slow to add, with icons disappearing for a second, and laggy loading. 
**Moving the smart collection site to the top is fast, comparing to a baseline of how we move apps on the homescreen.

Flame 2.1 build:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.034958
FW-Date         Thu Dec  4 03:50:09 EST 2014
Bootloader      L1TC00011880

Flame 2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ff1100ba2ab8
Build-ID        20141204000228
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.040425
FW-Date         Thu Dec  4 04:04:36 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.