Open Bug 1033611 Opened 6 years ago Updated 11 months ago

[geckoview] IndexedDb fails on pages loaded from the Assets using jar:file protocol

Categories

(GeckoView :: General, defect, P5)

All
Android
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: dpupek, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Created a GeckoView with the following prefs:
PrefsHelper.setPref("dom.indexedDB.enabled", true);

I loaded a page into a GeckoView. In javascript I Attempted to call:
window.indexedDB.open("MyTestDatabase", 3);

I also tried this same code in the console on the remote debugger.


Actual results:

In javascript the following was thrown:

[Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: debugger eval code :: <TOP_LEVEL> :: line 1"  data: no]

In logcat no errors appeared.


Expected results:

It should have open a database and passed a reference to it.
Blocks: geckoview
I should note that this file was loaded from the Assets directory using the jar:file formated URL
OS: Windows 7 → Android
Hardware: x86_64 → x86
xref bug 1033622 for localStorage, probably the same root cause and same fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: IndexedDb fails in GeckoView → IndexedDb fails in GeckoView on pages loaded from the Assets using jar:file protocol
This probably a good case for fixing Bug 948465

That would allow us to not have to use the jar:file protocol
Hardware: x86 → All
Summary: IndexedDb fails in GeckoView on pages loaded from the Assets using jar:file protocol → [geckoview] IndexedDb fails on pages loaded from the Assets using jar:file protocol
Mass change of bugs in the "Embedding: GRE Core" component in preparation for archiving it. I believe that these are no longer relevant; but if they are, they should be reopened and moved into a component relevant to the code in question.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Product: Core → Core Graveyard
Reopening and moving to Core::Embedding: APIs, where we'll continue to triage and track GeckoView issues, but this might be wontfix if it isn't useful now that bug 948465 has been fixed.
Status: RESOLVED → REOPENED
Component: Embedding: GRE Core → Embedding: APIs
Product: Core Graveyard → Core
Resolution: INCOMPLETE → ---
Component: Embedding: APIs → GeckoView
Product: Core → Firefox for Android
Kevin, can you see if this still happens?
Flags: needinfo?(kbrosnan)
Temporary p5 until I get a chance to investigate.
Priority: -- → P5
Product: Firefox for Android → GeckoView
You need to log in before you can comment on or make changes to this bug.