Password for remembered username does not pre-fill

RESOLVED DUPLICATE of bug 433238

Status

()

defect
RESOLVED DUPLICATE of bug 433238
5 years ago
5 years ago

People

(Reporter: pieman, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1) On a login page that has a "Remember my user ID on this computer" or similar check box, e.g. http://My.FedEx.com , log in and check the box to remember the UN.

2) Allow Firefox PW Manager to remember the PW for that UN.

3) Log out, close the window/tab.

4) Open a new window/tab to the same page.



Actual results:

1) The username is pre-filled by the web page, but PW Manager does not pre-fill the PW. 

2) Double clicking the username field and selecting the same username from the field entry memory, now the PW pre-fill works.


Expected results:

When the page first appears, PW Manager should automatically pre-fill the PW corresponding to the UN pre-filled by the site.
Reporter

Comment 1

5 years ago
Did not see this earlier, but likely the same issue as https://bugzilla.mozilla.org/show_bug.cgi?id=493377.
Hi Scott,

thanks for taking the time to report a problem.

Does it happens with all sites with a login form? Or just to that one (or a set of sites, but not all)? Because in the one you mentioned, there's a autocomplete="off" parameter in the pw form and this is the reason of the behaviour. In this case, it's working as designed.

If instead it happens to you with all sites with a login form, then could very well be a problem on Firefox' end.
If that's the case: could you please check if the issue is present also in Safe Mode (Help → Restart with Addons Disabled)? And with a clean profile? (see here how to create one → http://kb.mozillazine.org/Profile_Manager).
This will help us know if the culprit is some extensions or a specific setting in your profile.

Cheers,
Francesca
Flags: needinfo?(pieman)

Comment 3

5 years ago
> Because in the one you mentioned, there's a autocomplete="off" parameter in the pw form and this is the reason of the behaviour.

Maybe not: bug 956906.

> If instead it happens to you with all sites with a login form,

or if it happens when the site does something to one of the fields?
Component: Untriaged → Password Manager
Product: Firefox → Toolkit
We are honouring the wishes of page because it set autocomplete=off on the password field. In this case we will still ask to remember the password (bug 956906) but we won't autofill it. You need to focus the username field and tab out once the username value is typed or by choosing the username from the dropdown (your Actual Result #2). Making this easier to discover could be solved by bug 433238.

(In reply to [:Aleksej] from comment #3)
> > Because in the one you mentioned, there's a autocomplete="off" parameter in the pw form and this is the reason of the behaviour.
> 
> Maybe not: bug 956906.

That bug is about saving, not filling. Saving is working fine.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(pieman)
Resolution: --- → DUPLICATE
Duplicate of bug: 433238
Reporter

Comment 5

5 years ago
It is not with all forms, the one was an example where it happens. Even though autocomplete may be "off", it does autocomplete the password when the steps listed are taken. 

It is important to note that the behavior I described is only when the SITE auto-fills a site-remembered username. If you doubleclick and choose a BROWSER-remembered field entry, then the password is auto-filled.
Reporter

Comment 6

5 years ago
I regret my ability to help with research is limited.
Thanks Scott. You gave good information. autocomplete=off is interpreted by Firefox nowadays to mean "don't auto-fill this field" which is what you are seeing.
You need to log in before you can comment on or make changes to this bug.