Closed Bug 1033950 Opened 5 years ago Closed 5 years ago

[Settings] update selectors in AMDed wifi panel from #id to .class

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S2 (15aug)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified

People

(Reporter: eragonj, Assigned: eragonj)

References

Details

(Whiteboard: [p=1])

Attachments

(2 files)

This is a follow-up bug trying to replace all #id selector with .class selector to make our codebase more consistent.
Comment on attachment 8463300 [details] [review]
patch on master

Hi Zac and Arthur,

can you guys help me review this patch ?

This patch focuses on updating the selectors and that's all !

THanks :)
Attachment #8463300 - Flags: review?(zcampbell)
Attachment #8463300 - Flags: review?(arthur.chen)
Whiteboard: [p=1]
Target Milestone: --- → 2.1 S2 (15aug)
Comment on attachment 8463300 [details] [review]
patch on master

r+
Attachment #8463300 - Flags: review?(zcampbell) → review+
Comment on attachment 8463300 [details] [review]
patch on master

r=me, thanks!
Attachment #8463300 - Flags: review?(arthur.chen) → review+
thanks all, merged into Gaia/master : https://github.com/mozilla-b2g/gaia/commit/af9a0a24fb9f4c5ced3602bc14053bd49b136344
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Back this out as it breaks the wifi panel:

522a48d5ddf87916c3e6155dc92f7b3c040fc15b
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Arthur I just re-scanned all files again with changed strings and also found two missing cases (one in style file while the other one is using document.getElementById).

Because this new patch doesn't modify anything in Python, I only set r? on you, thanks !!
Attachment #8467600 - Flags: review?(arthur.chen)
Comment on attachment 8467600 [details] [review]
patch on master (fix failed cases)

r=me, thanks!
Attachment #8467600 - Flags: review?(arthur.chen) → review+
Depends on: 1048893
THanks all, merged into Gaia/master: https://github.com/mozilla-b2g/gaia/commit/5e6ef81cb9e917657ce050f598229dfc83c58b8f#diff-d41d8cd98f00b204e9800998ecf8427e
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Based on Comment 11 of bug 1048893 I am verifying this bug. This Issue is verified fixed on 2.1 Flame 319MB and 512MB.

Environmental Variables:
Device: Flame Master 319MB and 512MB
Build ID: 20140806040201
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: 6cbdd4d523a7
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
Group: core-security
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Group: core-security
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
2.1+ this fixed regression because this is a smoketest failure, see bug 1048893.
blocking-b2g: --- → 2.1+
You need to log in before you can comment on or make changes to this bug.