[Flame][Stage] Erase functionality not working on today's 2.0 build

RESOLVED DUPLICATE of bug 1032903

Status

Firefox OS
FindMyDevice
RESOLVED DUPLICATE of bug 1032903
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: _6a68)

Tracking

({regression})

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

Attachments

(1 attachment)

Created attachment 8450172 [details]
erasedevice.txt

Flame, while running:

Gaia   7ad00b0bd84d5d97e0801e3b3ceaac33fcd90e05
SourceStamp e87f7b398fce
BuildID 20140703000248
Version 32.0a2
Base 122

1. Set up phone on stage.
2. Successfully located device.
3. Attempt ring and lost mode - both work.
4. Attempt to erase device from website - fails after multiple tries.

I performed an OTA, and then reset the phone after making sure the prefs were set.

Log attached with gaia debug and geolocation traces set.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?
(Assignee)

Comment 1

4 years ago
Taking, since I've had my head in the erase code this week.

I suspect this will be fixed by the fixes for bug 1032903, but let's leave this open for the moment and reverify after that lands.
Assignee: nobody → 6a68

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Keywords: regression
I saw errors in logcat when trying the erase feature:

07-05 12:53:11.674  1166  1166 E GeckoConsole: [JavaScript Error: "NS_ERROR_UNEXPECTED: " {file: "app://findmydevice.gaiamobile.org/gaia_build_defer_index.js" line: 81}]
07-05 12:53:11.674  1166  1166 I GeckoDump: [findmydevice] enumerating sdcard resulted in a null file?
07-05 12:53:11.674  1166  1166 E GeckoConsole: [JavaScript Error: "NS_ERROR_UNEXPECTED: " {file: "app://findmydevice.gaiamobile.org/gaia_build_defer_index.js" line: 81}]
07-05 12:53:11.674  1166  1166 I GeckoDump: [findmydevice] enumerating videos resulted in a null file?
07-05 12:53:11.684  1166  1166 E GeckoConsole: [JavaScript Error: "NS_ERROR_UNEXPECTED: " {file: "app://findmydevice.gaiamobile.org/gaia_build_defer_index.js" line: 81}]
07-05 12:53:11.684  1166  1166 I GeckoDump: [findmydevice] enumerating music resulted in a null file?
07-05 12:53:11.694  1166  1166 E GeckoConsole: [JavaScript Error: "NS_ERROR_UNEXPECTED: " {file: "app://findmydevice.gaiamobile.org/gaia_build_defer_index.js" line: 81}]
07-05 12:53:11.694  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140703125006
07-05 12:53:11.704  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140703125006
07-05 12:53:11.714  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140703155034
07-05 12:53:11.714  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140703155034
07-05 12:53:11.714  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140703162446
07-05 12:53:11.734  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140703162446
07-05 12:53:11.744  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140703165022
07-05 12:53:11.744  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140703165022
07-05 12:53:11.764  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140704130407
07-05 12:53:11.764  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140704130407
07-05 12:53:11.764  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140616171114
07-05 12:53:11.774  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140616171114
07-05 12:53:11.774  1166  1166 I GeckoDump: [findmydevice] deleting: InstallTime20140705123522
07-05 12:53:11.784  1166  1166 I GeckoDump: [findmydevice] done deleting InstallTime20140705123522
07-05 12:53:11.784  1166  1166 I GeckoDump: [findmydevice] enumerating crashes resulted in a null file?
07-05 12:53:11.784  1166  1166 E GeckoConsole: [JavaScript Error: "NS_ERROR_UNEXPECTED: " {file: "app://findmydevice.gaiamobile.org/gaia_build_defer_index.js" line: 81}]

Updated

4 years ago
Target Milestone: --- → 2.1 S6 (10oct)

Updated

4 years ago
Target Milestone: 2.1 S6 (10oct) → 2.0 S6 (18july)
(Assignee)

Comment 3

4 years ago
I'm going to mark this as a dupe of bug 1032903, since that contains my erase fix, and it didn't land until July 8 in master, and July 9 in 2.0.

Please reopen if it's still a problem.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032903
You need to log in before you can comment on or make changes to this bug.