Closed Bug 1032903 Opened 6 years ago Closed 6 years ago

Erasing the device with SD card as default doesn't erase internal memory

Categories

(Firefox OS Graveyard :: FindMyDevice, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: marcia, Assigned: _6a68)

References

Details

Attachments

(2 files)

Flame, while running:

Gaia   90bb898e8401f5fb98edcf38293073c5c26ab7bd
SourceStamp 83c09fe3a658
BuildID 20140701040201
Version 33.0a1

SD Card is the default in this testing, but there is data in both internal memory and on SD card.

STR:
1. With the SD card set as the default, perform an erase command from the FMD website

Expected: Everything on the device gets wiped, including my internal memory
Actual: The internal memory doesn't get wiped.
can we erase the 'apps' type?  that will enumerator /data/.  To do this, we need to have the "webapps-manage" permission.
Good call, Doug. I'll add that to the patch.
Assignee: nobody → 6a68
Duplicate of this bug: 1032976
Nominated because, unless this is fixed, the remote wipe feature will not work properly, and will only erase some of the device storage.
blocking-b2g: --- → 2.0?
Attached file Github PR 21296
Attachment #8449546 - Flags: review?(ggoncalves)
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8449546 [details] [review]
Github PR 21296

Unsetting r? while I respond to review feedback.
Attachment #8449546 - Flags: review?(ggoncalves)
Comment on attachment 8449546 [details] [review]
Github PR 21296

Hey man,

This needs to be tested again on device, but thought I'd get your feedback anyhow.

I've got the utils ready to be pulled out into a separate file, and I decided to just replace the counter incrementing with Promises-based flow control. I think it looks cleaner.

Mind having a look?

Cheers,

Jared
Attachment #8449546 - Flags: review?(ggoncalves)
Target Milestone: --- → 2.0 S6 (18july)
Duplicate of this bug: 1032900
I've *finally* got my fix working reliably, thanks to lots of help from dhylands and dougt and ggp.

Hopefully have this merged in the morning.
Attachment #8449546 - Flags: review?(ggoncalves) → review+
Followup bug to refactor the format/erase methods out to a separate utils file: bug 1036019
kgrandon reports in #gaia that the marionette failures in the latest try job[1] are not a big deal, merging.

[1] https://tbpl.mozilla.org/?rev=e051b2b181ebd9b5020dfff42c316e1a81de5ab6&tree=Gaia-Try
Master: https://github.com/mozilla-b2g/gaia/commit/ea3164a2b1e82a40de05ad8393f99d762fb9fe33
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1034057
This issue has been successfully verified on Flame v2.1&2.0.
See attachment: verified_v2.1.mp4.
Reproduce rate: 0/4.

STR:
1. Change "Default media location" to "SD card" on device,
2. Sign in the FMD account on device and PC.
3. Set Lost mode.
**The device into Lost mode.
4. Set Erase.
**Device will restore the factory.
5. Skip FTU and enable USB storage on device.
6. Plug in USB cable.
**Both internal memory and SD card was wiped(deleting all data on internal memory and SD card).

Flame 2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ff1100ba2ab8
Build-ID        20141204000228
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.040425
FW-Date         Thu Dec  4 04:04:36 EST 2014
Bootloader      L1TC00011880

Flame 2.1 build:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.034958
FW-Date         Thu Dec  4 03:50:09 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.