Turn off xpcshell tests on Tegras

RESOLVED DUPLICATE of bug 1033507

Status

RESOLVED DUPLICATE of bug 1033507
4 years ago
5 months ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We can't land structured logging for xpcshell without some undesirable hacks, because they're running on Tegras with no mozharness support.

We don't really need xpcshell tests on Tegras; we have the same coverage on 2.x on emulators already.

Let's just turn xcpshell tests on Tegras off.

Updated

4 years ago
Blocks: 1033507
(Reporter)

Comment 1

4 years ago
It looks like this isn't enough to prevent us from having to hack tsets.zip, since Thunderbird runs xpcshell tests as well, and they also don't run in mozharness.

So, we'll probably have to copy mozlog into test.zip's xpcshell directory.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
I don't think we should block useful work on Thunderbird.

Comment 3

4 years ago
xpcshell tests have already been disabled on tegras in bug 1033507.
No longer blocks: 1033507
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1033507

Updated

4 years ago
No longer blocks: 1033126
(Assignee)

Updated

5 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.