disable tegras on 32 to ride the trains

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kmoir, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 3 obsolete attachments)

(Assignee)

Description

3 years ago
bye bye tegras
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
(Assignee)

Updated

3 years ago
Blocks: 1016453

Comment 1

3 years ago
Christmas has come early! :-D

Updated

3 years ago
Depends on: 1034221
(Assignee)

Comment 2

3 years ago
Created attachment 8451117 [details] [diff] [review]
bug1033507.patch
(Assignee)

Comment 3

3 years ago
Created attachment 8451129 [details] [diff] [review]
bug1033507builder.diff

builder diff
(Assignee)

Comment 4

3 years ago
Created attachment 8451130 [details]
bug1033507builder.diff
Attachment #8451129 - Attachment is obsolete: true
(Assignee)

Comment 5

3 years ago
As I mentioned before in bug https://bugzilla.mozilla.org/show_bug.cgi?id=1017599#c6

I don't know how to disable talos on a per branch basis until we turn off all Tegra tests.  

Actually now that we have all tests off on certain bramches if I turn off builds on those branches, no talos tests will be invoked.  Let me write a patch for that.
(Assignee)

Comment 6

3 years ago
Created attachment 8451689 [details] [diff] [review]
bug1033507-2.patch
Attachment #8451117 - Attachment is obsolete: true
Attachment #8451689 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 7

3 years ago
Created attachment 8451692 [details] [diff] [review]
bug1033507builder.diff

builder diff
Attachment #8451130 - Attachment is obsolete: true
(Assignee)

Comment 8

3 years ago
Callek: I looked at disabling the builds but of course the armv6 apks are still used for 2.3 tests and the android apks are used for 4.0.  So I don't know a good way to disable the associated talos tests for tegras.

If you have suggestions, I'd appreciate them.

See comment #5.

Updated

3 years ago
Attachment #8451692 - Attachment is patch: true
Attachment #8451692 - Attachment mime type: text/x-patch → text/plain
Comment on attachment 8451689 [details] [diff] [review]
bug1033507-2.patch

Review of attachment 8451689 [details] [diff] [review]:
-----------------------------------------------------------------

r- purely because its removing them from aurora as well per the builder diff.

I'd also love a grep of "Tegra" in the full (after) builder list, to verify what branches are left, while we're at it.

To be clear, we *do* want to remove on try, effectively defeating the ability to mobile test beta/etc patches that land?
Attachment #8451689 - Flags: review?(bugspam.Callek) → review-
(Assignee)

Comment 10

3 years ago
My understanding is that it's supposed to be removed from the aurora because it will be removed from 32. In the mobile meeting it was mentioned that there would be a lack of test coverage during this change.  The same with try. I have already disabled selected tests on 32 in bug 1017599 which is reflected on Try and m-a.

I'll attach a grep of Tegra in the after builder list.
(Assignee)

Comment 11

3 years ago
Created attachment 8452295 [details]
Tegra.jul7

List of builders with Tegra after this change
Comment on attachment 8451689 [details] [diff] [review]
bug1033507-2.patch

Review of attachment 8451689 [details] [diff] [review]:
-----------------------------------------------------------------

Ok then. If be interested in knowing if the b2g* branches still want or need tegra as well
Attachment #8451689 - Flags: review- → review+
(Assignee)

Updated

3 years ago
Attachment #8451689 - Flags: checked-in+
(Assignee)

Comment 13

3 years ago
Callek: who should I ask re the b2g branches, not sure if the mobile test meeting is the best place.
In production
(Assignee)

Comment 15

3 years ago
From #ateam
blassey	go ahead and turn off talos tegras
kmoir	gbrown: I can needinfo blassey on that bug and see if we can disable all talos on tegras
jmaher	blassey++
kmoir	blassey++

So I'll attach a patch to disable all talos testing on tegras
(In reply to Kim Moir [:kmoir] from comment #13)
> Callek: who should I ask re the b2g branches, not sure if the mobile test
> meeting is the best place.

I'm not sure, n-i to :aki to redirect.

For enumeration, kim, which branches are running which tests, with which builds against tegras?
Flags: needinfo?(aki)

Comment 17

3 years ago
b2g30 has none: https://tbpl.mozilla.org/?tree=Mozilla-B2g30-v1.4
I'm going to follow that pattern for b2g32.
Flags: needinfo?(aki)
(Assignee)

Comment 18

3 years ago
Created attachment 8454595 [details] [diff] [review]
bug1033507Talos.patch

patch to disable Talos tests on Tegra across all branches
Attachment #8454595 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 19

3 years ago
Created attachment 8454596 [details]
byebyeTegrasTalos

builder diff
(Assignee)

Comment 20

3 years ago
Created attachment 8454598 [details]
remainingTegrajobs

List of remaining Tegra jobs after disabling Talos
Comment on attachment 8454595 [details] [diff] [review]
bug1033507Talos.patch

Review of attachment 8454595 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/mobile_config.py
@@ +119,1 @@
>  ANDROID_NOT_PANDA = [slave_plat for slave_plat in ANDROID if 'panda' not in slave_plat]

ANDROID_NOT_PANDA will now be an empty list, followup fodder.

@@ +1658,5 @@
>              if not branch['platforms'][platform][slave_plat]['debug_unittest_suites']:
>                  continue
>              else:
>                  branch['platforms'][platform]['enable_debug_unittests'] = False
> +A

accidental insertion
Attachment #8454595 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 22

3 years ago
http://hg.mozilla.org/build/buildbot-configs/rev/45d2362b9356 to disable all Talos tests
(Assignee)

Comment 23

3 years ago
verified on tbpl
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
No longer depends on: 1034221
Duplicate of this bug: 1034221

Updated

3 years ago
Blocks: 1033126
You need to log in before you can comment on or make changes to this bug.