Closed Bug 1034487 Opened 5 years ago Closed 5 years ago

Needs a way to stop, clear the profile/content, start b2g between tests on device

Categories

(Testing Graveyard :: JSMarionette, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 994847

People

(Reporter: zcampbell, Unassigned)

References

Details

To attain the same stability that desktopb2g achieves on device we will need to wipe the device's profile and other persistent data between stopping and starting b2g.  (It will auto-generate a fresh one).

The data we need to wipe is already known from Python experience and is here:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/gaia_test.py#L703
Blocks: 1034504
This should also take into account stopping and starting b2g.

Some work is being done here but not in the test runner that will benefit integration tests:
https://bugzilla.mozilla.org/show_bug.cgi?id=1027232
Summary: Needs a way to clear the profile and content between tests on device → Needs a way to stop, clear the profile/content, start b2g between tests on device
Depends on: 994764
IMO, based on observations, is that restart behaviour should be the default. This way it matches CI and is the most reliable way to run the tests.
This one is definitely a dupe of bug 994847. That bug is essentially all about using mozrunner to stop/start b2g processes and devices.

Right now all gaia-integration tests are restart b2g in between each test. This is going to be problematic if we want to run them per-commit though because rebooting the device between tests takes a really *long* time. It'll be hard to get enough devices to run the full suite at volume.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994847
Ahal, what about clearing the profile - will mozrunner do that too?
Yes, though in the case of gaia-integration it's a little different because each test has a unique profile specifically built for it.
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.