Closed Bug 1035076 Opened 5 years ago Closed 5 years ago

Measure vsync event latency between VsyncDispatcher and other modules in Project Silk

Categories

(Firefox OS Graveyard :: Performance, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 991420
2.1 S5 (26sep)

People

(Reporter: jerry, Assigned: jerry)

References

Details

(Keywords: perf, Whiteboard: [c=uniformity p= s= u=])

Attachments

(1 file)

We need to measure the vsync event latency to check the benefit while we propose a new idea to Project Silk.
Keywords: perf
Whiteboard: [c=uniformity p= s= u=]
Priority: -- → P2
I didn't measure anything, but playing with a flame, I changed the RT priority to 1, NICE values from -8, -4, and -1 and 0. -8, and -4 correspond to android DISPLAY and DISPLAY_URGENT priorities. If we set the NICE value to anything great than 0, it actually feels jankier because we can't process touch events. We also checkerboard more. Like you said Jerry, raising the priority might be too high, anything other than the default at the moment might be too high. Will test more later.
Just measuring composite uniformity with different devices. I have 2 devices, Flame and Nexus 4. I have 5 profiles up with different compositor priorities. Vsync seems a little cleaner, but still kind of noisy. We should probably dig into why this is happening. 

Composite Uniformity

Nexus 4, Silk, Compositor Nice -2
https://people.mozilla.org/~bgirard/cleopatra/#report=d9df6de66939d9f5490e9d84cdb1552869e64406

Nexus 4, Silk, Compositor Nice 0
https://people.mozilla.org/~bgirard/cleopatra/#report=2943a583e851ad99565a9cee995a0acec3e77e6e

Nexus 4, Master, no changes
https://people.mozilla.org/~bgirard/cleopatra/#report=cf13a0568892a7c890e8bcfae0c2fdc88b6af00e

Flame Silk, Compositor Nice 0
https://people.mozilla.org/~bgirard/cleopatra/#report=21c1cb9e6ba649dff102913d46be092f60358366

Flame Master, No Changes
https://people.mozilla.org/~bgirard/cleopatra/#report=e0ecd08ce8d1eb23f652938df7b461ab7f729897
utils for Bug 987529

add vsync silk utils for logging dispatch latency.
applay part1 to 8 in Bug 987529 first.
Hi Mason,

For your test all spiral, the CompositorParent costs more than 16ms for one frame, so you will always see a large delay for CompositorParent.
You can use the systrace tool to check.
Blocks: Silk
Target Milestone: --- → 2.1 S5 (26sep)
Depends on: 988160
Depends on: 846535
See Also: → 991420
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991420
You need to log in before you can comment on or make changes to this bug.