[B2G][Settings][Downloads] Body of delete confirmation message is missing when deleting download

VERIFIED FIXED in 2.0 S6 (18july)

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: bzumwalt, Assigned: aus)

Tracking

({regression})

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: LocRun2.0 [systemsfe][p=1])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8451815 [details]
Screenshot

Description:
When one or more downloads are present in download manager selecting one or more then pressing delete brings up a confirmation message with no body. Title of confirmation message appears as "Delete" but no other information is present on screen. This issue occurs when deleting one or multiple files at a time. This issue occurs on active, complete, stopped, and any combination of these download status'.


Repro Steps:
1) Update a Flame to 20140707000200
2) Launch browser and download a zip file
3) Select notification to navigate to download manager
4) Press checkmark symbol and select one or more downloads
5) Select delete


Actual:
Confirmation message for delete download has no text in body. Only title appears.

Expected:
Title and body message appear in delete download confirmation screen.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140707000200
Gaia: ef67af27dff3130d41a9139d6ae7ed640c34d922
Gecko: f53099796238
Version: 32.0a2 (2.0) 
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 3/3, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12514/
See attached: screenshot
(Reporter)

Comment 1

5 years ago
Issue DOES occur on 2.1 Flame & 2.1 Buri

Environmental Variables:
Device: Flame 2.1
Build ID: 20140707040201
Gaia: 93daa354671a698634a3dc661c8c9dcb7d824c31
Gecko: 1dc6b294800d
Version: 33.0a1  
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.1
Build ID: 20140707040201
Gaia: 93daa354671a698634a3dc661c8c9dcb7d824c31
Gecko: 1dc6b294800d
Version: 33.0a1  
Firmware Version: v1.2device.cfg

User agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Actual Result: Confirmation message for delete download has no text in body. Only title appears.


Issue does NOT occur on 1.4 Flame & 1.4 Buri

Environmental Variables:
Device: Flame 1.4
Build ID: 20140707000200
Gaia: 5c9e1e4131d3ac8915ed88b72bb66dc7d97be6a0
Gecko: 2d0c15450488
Version: 30.0 (1.4) 
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Buri 1.4
Build ID: 20140707000200
Gaia: 5c9e1e4131d3ac8915ed88b72bb66dc7d97be6a0
Gecko: 2d0c15450488
Version: 30.0 (1.4) 
Firmware Version: v1.2device.cfg

User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual result: Title and body message appear in delete download confirmation screen.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
This also occurs for the unsupported file type screen.
(Reporter)

Updated

5 years ago
Keywords: regression
Nominating this 2.0? since this is a regression and important strings are missing.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Comment 4

5 years ago
Hi Candice, it's download manager related, could you take a look and assign? Thanks.
Flags: needinfo?(cserran)
Whiteboard: LocRun2.0 → LocRun2.0 [systemsfe]
blocking-b2g: 2.0? → 2.0+
QA Contact: pcheng
Hey Aus, can you take a look at this blocker?
Flags: needinfo?(cserran) → needinfo?(aus)
(Assignee)

Comment 6

5 years ago
But of course! I'm tinkering around in there already today for a different blocker. I'll update as I find out more. On the surface, should be a simple issue to resolve.
Assignee: nobody → aus
Flags: needinfo?(aus)
Target Milestone: --- → 2.0 S6 (18july)
(Assignee)

Comment 7

5 years ago
Created attachment 8452593 [details] [review]
Pull Request - Update download_ui.js so that it uses data-l10n-id and data-l10n-args instead of setting textContent directly.

Hooray for better l10n usage that magically fixes the issue! and makes us forward compatible.
Attachment #8452593 - Flags: review?(crdlc)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Whiteboard: LocRun2.0 [systemsfe] → LocRun2.0 [systemsfe][p=1]
Keywords: regressionwindow-wanted
Blocks: 926955
Comment on attachment 8452593 [details] [review]
Pull Request - Update download_ui.js so that it uses data-l10n-id and data-l10n-args instead of setting textContent directly.

LGTM, just a suggestion in Github
Attachment #8452593 - Flags: review?(crdlc) → review+
(Assignee)

Comment 9

5 years ago
Commit (master): https://github.com/mozilla-b2g/gaia/commit/6da21120e77b6a4ad878dd4531305cd393f6734c

Commit (v2.0): https://github.com/mozilla-b2g/gaia/commit/1cd5a8546959df287ec56fd619f68877148cd1f9

Fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED
Blocks: 1020138
Created attachment 8533063 [details]
video

This issue has been verified successfully on Flame 2.0 and 2.1
See attachment: Verify_1035367.MP4
Reproducing rate: 0/5

Flame2.0 build:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141207000206
Version         32.0

Flame2.1 build:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.