If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Flame][Music] Music app will not close after attempting to share through email in low memory environments

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: AdamA, Assigned: gduan, NeedInfo)

Tracking

({regression})

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 affected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [273MB-Flame-Support][2.0-exploratory][p=2], URL)

Attachments

(7 attachments)

(Reporter)

Description

3 years ago
Created attachment 8453892 [details]
logcat

Description:
When attempting to share songs from the music app through email repeatedly the music app will become stuck on the screen and will not close.

Repro Steps:
1) Update a Flame device to BuildID: 20140710000201
2) Set Phone memory to 273mb
3) Open email app (sign into an email account if not already signed in)
4) Switch to music app
5) Start playing a song
6) Choose to share the song through email
7) Cancel email and return to email app
8) Repeat steps 6-7 until it does not switch to email app (usually 1-2 times)
9) Press Home button
10) Observe music app remaining on screen

Actual:
Music app remains on screen and will not close

Expected:
it is expected that users are able to exit the music app

Environmental Variables:
Device: Flame v2.0 (273mb) Moz ril
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Keywords: E-mail, lock, stuck.


Notes:
This issue occurs whether or not the song is able to attach to the email.


Repro frequency: 90%
See attached: video clip(http://youtu.be/7GTo6pXgNgA), logcat

--------------------------------------------------

This issue also occurs on Flame 2.1 (273mb).

Environmental Variables:
Device: Flame Master (273mb)
BuildID: 20140709040203
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Actual:
Music app remains on screen and will not close

--------------------------------------------------

This issue does not occur on Flame 2.0 (512mb), Flame 1.4, Buri 1.4, Buri 2.0, Buri 2.1, Open_C 1.4, Open_C 2.0, Open_C 2.1, Flame Base v122, Flame Base v121-2.


Environmental Variables:
Device: Flame 2.0 (512mb)
BuildID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Flame 1.3
Build ID: 20140616171114
Gaia: e1b7152715072d27e0880cdc6b637f82fa42bf4e
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Environmental Variables:
Device: Buri Master
Build ID: 20140709073020
Gaia: c394b7b4205b6f1a6ca44915fc08650f3ad127ec
Gecko: 2d88803a0b9c
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140709063007
Gaia: 1774027323bb072b4ebdfea9883572bcf2535c87
Gecko: 11b6493a7d8f
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Buri 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Open_C Master
Build ID: 20140708040218
Gaia: 740faa5d0060fb218b407cf224330654ddf833a5
Gecko: 465280604ea6
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140709000201
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual:
Music app closes and other actions can be performed
(Reporter)

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
This is a regression from 1.4 and the user will not be able to close the music app after encountering this issue. Nominating this 2.0?
Status: UNCONFIRMED → NEW
blocking-b2g: --- → 2.0?
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Ever confirmed: true
Whiteboard: [273MB-Flame-Support][2.0-exploratory]

Updated

3 years ago
Component: Gaia::Music → Gaia::System::Window Mgmt
QA Contact: jmercado

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
George could you take and investigate this one?
Flags: needinfo?(gduan)
Assignee: nobody → gduan
Flags: needinfo?(gduan)
B2g-inbound Regression Window

Last working
Environmental Variables:
Device: Flame Master
BuildID: 20140604084216
Gaia: 2a4c7becdb141d2601e47a040a27eebe52a8db79
Gecko: fd5bb34861d6
Version: 32.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


First Broken
Environmental Variables:
Device: Flame Master
BuildID: 20140604105916
Gaia: 18e2e8dc2d9ff19cd1210026367c14956d04eb0d
Gecko: c36c5f011229
Version: 32.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Last working gaia / First broken gecko - Issue does NOT occur
Gaia: 2a4c7becdb141d2601e47a040a27eebe52a8db79
Gecko: c36c5f011229

First broken gaia / Last working gecko - Issue DOES occur
Gaia: 18e2e8dc2d9ff19cd1210026367c14956d04eb0d
Gecko: fd5bb34861d6

Gaia Pushlog:  https://github.com/mozilla-b2g/gaia/compare/2a4c7becdb141d2601e47a040a27eebe52a8db79...18e2e8dc2d9ff19cd1210026367c14956d04eb0d
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Jason - nothing in this pushlog covers Email or Music apps, is it possible this could be Vertical Homescreen related?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(jsmith)

Updated

3 years ago
Flags: needinfo?(jsmith) → needinfo?(kgrandon)
I found "07-10 10:25:39.230: E/GeckoConsole(291): [JavaScript Error: "TypeError: this.element is null" {file: "app://system.gaiamobile.org/js/app_window.js" line: 300}]" in the attachment, however , It looks like the bug is 'ONLY' reproducible on "273MB FLAME".

So I followed below instruction to reset my flame as 273MB
*** 1) adb reboot bootloader
*** 2) sudo fastboot oem mem 273 // Set memory limit to  273MB, 0 is auto(default)
*** 3) sudo fastboot getvar mem // Check if memory is set correctly
*** 4) sudo fastboot reboot.

Now, I can reproduce it after 273MB is set, but I can't find any gaia failure now.
Still investigating.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
I can't really see anything in that gaia pushlog, I don't think it's homescreen specific.

I also don't really understand the regression ranges here. "Last working gaia / First broken gecko" - it says that this does not reproduce the issue? What does "First broken gecko" refer to in this case?
Flags: needinfo?(kgrandon)
Followed with comment 5,
I can see the log as below now.
[JavaScript Error: "TypeError: this.element is null" {file: "app://system.gaiamobile.org/js/app_window.js" line: 300}]" in the attachment, however , It looks like the bug is 'ONLY' reproducible on "273MB FLAME".

but the line failed at 
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window.js#L1402

I think when we discard the mail and switch back to music, gecko print out memory pressure and kill the background app (email), because I can't find email process while doing 2nd time switching from email.
Sorry, should be failed at this line
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window.js#L303

Updated

3 years ago
Target Milestone: --- → 2.0 S6 (18july)
Created attachment 8455986 [details]
First time launch email through music app
Created attachment 8455988 [details]
Second time launch email through music app

Followed with comment 7,

When I set DEBUG as true to see full log of app_window.js, system app has actually handled handle_mozbrowsererror while email is killed, so system should have already done relaunch email activity.

I compare these two log file, first one is first time sharing music to email and second one is 2nd time sharing music to email, and I found there's only one log missing as below

07-15 07:25:17.809: E/GeckoConsole(299): Content JS LOG at app://system.gaiamobile.org/js/app_window.js:963 in aw_debug: [Dump: HomescreenWindow][Home screen][homescreen][40490.419] fade out >>>> 

and I also print out b2g-ps, I found homescreen is not in the list.
Created attachment 8455997 [details] [review]
PR to master

Hi Alive, 
could you take a look of my patch?
I think the root cause is the homescreen is killed in background due to memory pressure, and system do homescreen.fadeOut for some reason while launching activity. I think we should check this.element before doing that.
Attachment #8455997 - Flags: review?(alive)
Whiteboard: [273MB-Flame-Support][2.0-exploratory] → [273MB-Flame-Support][2.0-exploratory][p=2]
Comment on attachment 8455997 [details] [review]
PR to master

Cool, test please.
Attachment #8455997 - Flags: review?(alive) → review+
Duplicate of this bug: 1035507
Test added,
Thanks Alive.

Tbpl passed,
https://tbpl.mozilla.org/?rev=cdbee5ae54ee4e64cd446d56574144f8906c7470&tree=Gaia-Try

merge to master,
https://github.com/mozilla-b2g/gaia/commit/71cdbd38bc9321b53fa4d3004650512e871cc0d8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Issue has been resolved, removing unneeded QA-Wanted tags.
Keywords: regressionwindow-wanted
Duplicate of this bug: 1036673

Updated

3 years ago
See Also: → bug 1037204
v2.0: https://github.com/mozilla-b2g/gaia/commit/363e32deb090554ec27a4164f5c5a5b941b9037b
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed

Updated

3 years ago
Blocks: 1037204

Updated

3 years ago
Duplicate of this bug: 1037204
We need this patch.
Without this patch, we will meet homescreen no icon issue when monkey test.
status-b2g-v1.4: unaffected → affected
Flags: needinfo?(wchang)
Flags: needinfo?(ryang)
Flags: needinfo?(jason.liu)
Created attachment 8465973 [details]
jietu1.png

gaia debug snapshot
Created attachment 8465975 [details]
index.png

homescreen snapshot
Blocks: 1045451
Flags: needinfo?(yang.zhao)

Comment 22

3 years ago
With your patch and the STR in comment 0, I still could reproduce the issue on dolphin, it stays in music and couldn't go back to homescreen. I find the following error:
E/GeckoConsole(  107): [JavaScript Error: "TypeError: this.app.element is null" {file: "app://system.gaiamobile.org/js/app_transition_controller.js" line: 156}]

The error is printed in _do_opening,please see the codes:

149   AppTransitionController.prototype._do_opening =
150     function atc_do_opening() {
151       this._openingTimeout = window.setTimeout(function() {
152         this.app.broadcast('openingtimeout');
153       }.bind(this),
154       System.slowTransition ? this.SLOW_TRANSITION_TIMEOUT :
155                               this.TRANSITION_TIMEOUT);
156       this.app.element.classList.add('transition-opening');
157       this.app.element.classList.add(this.getAnimationName('open'));
158     };

I think we should resolve this error,too.Maybe we should check this.app.element in this file.Could you give me some suggestions? Thank you!
Flags: needinfo?(yang.zhao) → needinfo?(gduan)
Yang/James, I don't understand why you want to apply this patch in 1.4. Per comment 1 and comment 3, this is only reproducible on v2.0. V1.4 does not have this problem. The issue you saw in dolphin should be another issue.
Flags: needinfo?(yang.zhao)
Flags: needinfo?(james.zhang)
Hi Yang and James, looks like this issue doesn't exit on Dolphin.Let's keep monitoring it.
Besides,Replying comment19, I don't think we need re-based 1.4 patch for Dolphin. 
This is the regression issue from 1.4 to 2.0, thus only v2.0 needs to be solved.
Thanks.
Flags: needinfo?(wchang)
Flags: needinfo?(ryang)
Flags: needinfo?(gduan)

Comment 25

3 years ago
(In reply to Peipei Cheng from comment #23)
> Yang/James, I don't understand why you want to apply this patch in 1.4. Per
> comment 1 and comment 3, this is only reproducible on v2.0. V1.4 does not
> have this problem. The issue you saw in dolphin should be another issue.
Hi,peipei
  I test both WITH the patch and WITHOUT the patch, dolphin could reproduce the issue with the same log in comment 22.When the issue occurs,both music and homescreen are in foreground,and you couldn't back to homescreen. Although the result is the same, the root cause may be not the same. So maybe it's another issue.Thank you.
Flags: needinfo?(yang.zhao)
Flags: needinfo?(james.zhang)
Created attachment 8530819 [details]
video

This issue has been verified successfully on Flame 2.0 and 2.1
See attachment: Verify_1037041.MP4
Reproducing rate: 0/15
Flame 2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0

Flame 2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.