No link to home page/index page/urlbase on bug footer

RESOLVED FIXED in Bugzilla 2.18

Status

()

--
enhancement
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: sharding, Assigned: bugzilla)

Tracking

2.15
Bugzilla 2.18
Bug Flags:
approval +
approval2.18 +

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
It would be really nice to have a link back to the main bugzilla.mozilla.org web
page from the Bugzilla bugs page. Since there's no obviousl link, I always have
the impulse to click the Mozilla.org banner at the top of the page, which
obviously takes me back to www.mozilla.org...
Sean: what page are you talking about?  You did not specify a URL, and the only
page I can think of that fits your description (http://www.mozilla.org/bugs/)
has two links to bugzilla.mozilla.org within the first two paragraphs.
(Reporter)

Comment 2

17 years ago
I'm talking about virtually every page on http://bugzilla.mozilla.org/. This one
(http://bugzilla.mozilla.org/show_bug.cgi?id=103794), for example.

There's a link to /query.cgi, /enter_bug.cgi, /reports.cgi, /showvotes.cgi,
http://www.mozilla.org, etc., but no link back to / (http://bugzilla.mozilla.org/).
ok, in that case, this is a Bugzilla bug, and not something specific to
bugzilla.mozilla.org, since other than the main bugzilla.mozilla.org page
itself, the rest is all generated by the software.
Component: Bugzilla: Other moz.org Issues → User Interface
Product: mozilla.org → Bugzilla
Target Milestone: --- → Bugzilla 2.16
Version: other → 2.15
grr, forgot reassign to component owner
Assignee: endico → myk
QA Contact: myk → matty

Comment 5

17 years ago
Created attachment 56365 [details] [diff] [review]
Proposed link added

Comment 6

17 years ago
Added <A> tag to link the "Bugzilla version x.xx" at the top of every page
Summary: No link to http://bugzilla.mozilla.org/ on bug pages → No link to urlbase on bug footer
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Comment on attachment 56365 [details] [diff] [review]
Proposed link added

needs-work because its not templatised. We don't have that versoin text there
any more (as a side issue; why not? the version number in the table header is a
default)

Maybe linkify the "This is Bugzilla" at the bottom of the page?

We already link to bugzilla.org in the footer; do we still want this?
Attachment #56365 - Flags: review-
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk
This is a valid bug; we should have a link to the Bugzilla home page somewhere.
 I'm loath to add it to the footer for space reasons, but that'll change with
Gerv's redesign of the footer in bug 232338.
*** Bug 188983 has been marked as a duplicate of this bug. ***
*** Bug 230763 has been marked as a duplicate of this bug. ***
enhancements without a current patch are being pushed to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Summary: No link to urlbase on bug footer → No link to home page/index page/urlbase on bug footer
*** Bug 242172 has been marked as a duplicate of this bug. ***
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Comment 17

14 years ago
How complicated can this be?
(In reply to comment #17)
> How complicated can this be?

Probably easy enough that you could write a patch for it.  Go for it ;)
Hint: affected file is template/en/default/global/useful-links.html.tmpl
(Assignee)

Comment 19

14 years ago
Created attachment 159385 [details] [diff] [review]
Add a 'Home' link in the footer
Assignee: myk → bugzilla
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #159385 - Flags: review?
Attachment #159385 - Flags: review? → review?(myk)
Comment on attachment 159385 [details] [diff] [review]
Add a 'Home' link in the footer

Yeah, this is useful. r=myk
Attachment #159385 - Flags: review?(myk) → review+
This is such a small and low-risk change that I think it's worth getting into
2.18 as well for the sake of keeping the trunk and branch more in sync, although
it's not a blocker.
Flags: approval2.18+
Flags: approval+

Updated

14 years ago
Target Milestone: Bugzilla 2.22 → Bugzilla 2.18
(Assignee)

Comment 22

14 years ago
Could someone check this in for me please?
Hmm, taking another look, shouldn't this be pointing to index.cgi rather than
urlbase?
(Assignee)

Comment 24

14 years ago
(In reply to comment #23)
> Hmm, taking another look, shouldn't this be pointing to index.cgi rather than
> urlbase?

But how can we tell it is index.cgi, and not index.html, or some other home page the admin has 
configured as a default page? What do you think is wrong with just using urlbase?

why not use href="./" ?  We have no subdirectories containing cgis that dump
templates, and if we ever do, lots of things will have to be fixed to support it
anyway.
Good point.  Ok, checked in to 2.18 branch and trunk:

Checking in template/en/default/global/useful-links.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/useful-links.html.tmpl,v
 <--  useful-links.html.tmpl
new revision: 1.32; previous revision: 1.31
done
Checking in ../bz218/template/en/default/global/useful-links.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/useful-links.html.tmpl,v
 <--  useful-links.html.tmpl
new revision: 1.27.2.1; previous revision: 1.27
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.