Closed Bug 1037942 Opened 6 years ago Closed 6 years ago

[Keyboard] Alternative keys merged at Symbol Layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: raniere, Assigned: timdream)

References

Details

(Keywords: regression, Whiteboard: [p=1])

Attachments

(1 file)

Steps to Reproduce:

1. Open a app that use the keyboard.
2. Switch to symbols layout.
3. Long press the dollar symbol key.

Actual Results

There is only one alternative key that input "€ £ ¥".
	 
Expected results

Should be three alternatives keys: €, £ and ¥.
Blocks: 1029356
Keywords: regression
Tim, bug filed as you suggested.
Flags: needinfo?(timdream)
Thanks, taking.
Assignee: nobody → timdream
Status: UNCONFIRMED → ASSIGNED
blocking-b2g: --- → 2.1?
Ever confirmed: true
Flags: needinfo?(timdream)
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S6 (18july)
Comment on attachment 8455006 [details] [review]
mozilla-b2g:master PR#21654

Rudy, could you review this patch to fix a regression? Thanks!
Attachment #8455006 - Flags: review?(rlu)
Comment on attachment 8455006 [details] [review]
mozilla-b2g:master PR#21654

Raniere, would you mind apply the patch locally to see if this patch works?

You can do 

curl https://github.com/mozilla-b2g/gaia/pull/21654.patch | patch -p1

to apply the patch on your work directory (be sure to stage or commit your work so they don't mix up)

Thanks!
Attachment #8455006 - Flags: feedback?(ra092767)
Comment on attachment 8455006 [details] [review]
mozilla-b2g:master PR#21654

> Raniere, would you mind apply the patch locally to see if this patch works?

Works for me. Thanks.
Attachment #8455006 - Flags: feedback?(ra092767) → feedback+
Blocks: 1011482
Comment on attachment 8455006 [details] [review]
mozilla-b2g:master PR#21654

r=me, thanks.

--
Raniere, thanks for filing and feedback on this issue.
Attachment #8455006 - Flags: review?(rlu) → review+
master: https://github.com/mozilla-b2g/gaia/commit/0e6b5fec5eb508c5a94115555906261f8d809825
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
blocking-b2g: 2.1? → 2.1+
Issue verified as fixed on Flame 2.1 and Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.1 shows ¥, €, £, ¢, ₠ when long pressing $ on keyboard
2.2 shows $, €, £, ¢, ¥ when long pressing $ on keyboard

Double-checked current master to ensure verification
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.