Extend UITest app to be able to do hardware buttons testing

RESOLVED FIXED in 2.1 S3 (29aug)

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dwi2, Assigned: johnhu)

Tracking

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FT:Stream3])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
After bug 989198 lands, we should make UITest app to test this feature.
(Reporter)

Updated

4 years ago
Assignee: nobody → tzhuang

Updated

4 years ago
feature-b2g: --- → 2.1

Updated

4 years ago
Blocks: 1031141
Steal this bug from dwi2, since he is busy on other issues.
Assignee: tzhuang → johu
According to wiki[1], I will add a page to uitest-privileged app to capture the following 4 keys and try to cancel them:

*. Power
*. Exit
*. VolumeUp
*. VolumeDown

The expected behavior is VolumeUp and VolumeDown can be intercepted by app and cancelled.

[1] https://wiki.mozilla.org/WebAPI/BrowserAPI/KeyboardEvent#Part_2_-_Key_event_handling_customization
A WIP patch can be found here:
https://github.com/huchengtw-moz/gaia/commit/abd347f400d9fed0cd3312954fe74cf8da7cf04e

This WIP patch depends on the patch of bug 1014418 and bug 989198.
Created attachment 8471451 [details] [review]
patch for this bug

Hi AlTasi,

This patch needs bug 1014418 and bug 989198 to work or we can build a workable version for you. Please give us some feedback.
Attachment #8471451 - Flags: feedback?(atsai)

Comment 5

4 years ago
Plan to land it by the end of v2.1 sprint 3 (August 29).
Target Milestone: --- → 2.1 S3 (29aug)

Comment 6

4 years ago
A workable version of local build should be fine for me. I am still new to the project. Let me go to you for more details.

Comment 7

4 years ago
Comment on attachment 8471451 [details] [review]
patch for this bug

The patch seems good to me. Should I wait for the other two fixes for other bugs ready and execute testing?
Attachment #8471451 - Flags: feedback?(atsai) → feedback+
Bug 989198 may need to refactor to fix a critical issue. I will create a workable version for you once it is ready.

Updated

4 years ago
No longer blocks: 1031141

Comment 9

4 years ago
Confirmed with EM/EPM, and this can be landed before FL.

Comment 10

4 years ago
It doesn't look like a strong need to be landed in 2.1 and also we already passed the feature landing date for 1 week. Postpone this to the next version for now.
feature-b2g: 2.1 → 2.2?
Created attachment 8523726 [details] [review]
patch for this bug

atsai,

This PR is similar to the previous one. The difference is that we may need to focus the iframe while test opened. I recreate the PR because the previous one is closed by other guys.

Please review this patch.

BTW, the prevent default behavior is malfunction because of bug 1094066. We may use this to test that issue.
Attachment #8471451 - Attachment is obsolete: true
Attachment #8523726 - Flags: review?(atsai)

Comment 12

4 years ago
Comment on attachment 8523726 [details] [review]
patch for this bug

R=me. Good to merge.
Attachment #8523726 - Flags: review?(atsai) → review+
merged:
https://github.com/mozilla-b2g/gaia/commit/824a61cccec4c69be9a86ad5cb629a1f61fa142f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
feature-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.