Closed Bug 1038298 Opened 5 years ago Closed 5 years ago

[B2G][Everything.me]E.me apps are not displayed and cannot be added to the homescreen after OTA

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1037556
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: astole, Assigned: kgrandon)

References

Details

(Keywords: smoketest, Whiteboard: [systemsfe][ETA=7/18])

Attachments

(1 file)

Attached file logcat
After completing an OTA from 1.3 to 2.0, e.me apps do not display on the homescreen.

Repro Steps:
1) Update a Flame to v122 and latest 1.3 Gaia
2) Add e.me app to homescreen (Twitter used during test)
4) Turn on Wifi
5) Open Settings > Device Information
6) Select 'Check for updates'
7) When update found select the notifications menu
8) Download and install the update
9) Unlock phone and proceed to Homescreen

Actual:
E.me app does not display on homescreen

Expected:
E.me apps appear on the homescreen

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140714000202
Gaia: ca022f811bcbbda0f89086094a9e92bb220fea18
Gecko: 376889ab0e02
Version: 32.0a2
Firmware Version: v122

Repro frequency: 100%
See attached: logcat
QA Whiteboard: [QAnalyst-Triage?]
Keywords: smoketest
Nominating to block 2.0 on severity.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Note: Unable to add E.me apps to the homescreen even after completing OTA.
Summary: [B2G][Everything.me]E.me apps are not displayed after OTA → [B2G][Everything.me]E.me apps are not displayed and cannot be added to the homescreen after OTA
blocking-b2g: 2.0? → 2.0+
Blocks: 1015336
QA Whiteboard: [QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking+] [QAnalyst-Triage+]
Whiteboard: [systemsfe]
Assignee: nobody → kgrandon
Target Milestone: --- → 2.0 S6 (18july)
Whiteboard: [systemsfe] → [systemsfe][ETA=7/18]
Flags: needinfo?(ran)
Flags: needinfo?(kgrandon)
Flags: needinfo?(amir)
Sounds like a duplicate of bug 1037556?
Flags: needinfo?(kgrandon)
Yeah, let's mark as a dupe against bug 1037556 as we have a lot of good information in there.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ran)
Flags: needinfo?(amir)
Resolution: --- → DUPLICATE
Duplicate of bug: 1037556
I'm not sure if I agree as smart collection versus e.me app/homescreen bookmarks have a different behavior post update.  Having said, that I guess we would have to see after the patch lands in terms of how it is fixed.

We would need to verify both bug reports.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> I'm not sure if I agree as smart collection versus e.me app/homescreen
> bookmarks have a different behavior post update.  Having said, that I guess
> we would have to see after the patch lands in terms of how it is fixed.
> 
> We would need to verify both bug reports.

Ok, good point. Cristian is currently looking into bug 1037556, let's add a ni? to get his thoughts.
Flags: needinfo?(crdlc)
I think that both of them should work in the same way. I have to talk with Carmen in order to know what she has discovered yesterday

(In reply to Kevin Grandon :kgrandon from comment #6)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #5)
> > I'm not sure if I agree as smart collection versus e.me app/homescreen
> > bookmarks have a different behavior post update.  Having said, that I guess
> > we would have to see after the patch lands in terms of how it is fixed.
> > 
> > We would need to verify both bug reports.
> 
> Ok, good point. Cristian is currently looking into bug 1037556, let's add a
> ni? to get his thoughts.
Flags: needinfo?(crdlc)
You need to log in before you can comment on or make changes to this bug.