Closed Bug 1037556 Opened 5 years ago Closed 5 years ago

[B2G][OTA] Smart collections are not displayed after OTA 1.3 to 2.0

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jschmitt, Assigned: crdlc)

References

Details

(Keywords: smoketest, Whiteboard: [systemsfe])

Attachments

(4 files, 2 obsolete files)

Attached file log.txt
Description:
Smart Collections are not displayed after updating the phone from 1.3 to 2.0

Pre-requisites:
Make gaia on top of base image for 1.3 Flame setup
Push Smoketest Profile to DUT
Using B2G-Flast-Tool run these two lines:

./change_channel.sh -v aurora

./change_ota_url.sh~ -u https://aus4.mozilla.org/update/3/B2G/28.0/20140711000201/flame/en-US/aurora/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1

Repro Steps:
1) Update a Flame to 20140711000201
2) Turn on Wifi
3) Open Settings > Device Information
4) Select 'Check for updates'
5) When update found select the notifications menu
6) Download and install the update
7) Unlock phone and proceed to Homescreen

Actual:
Smart Collections are not displayed on the Homescreen.

Expected:
Smart Collections is displayed on the Homescreen.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140711000201
Gaia: 18c44a1bc31b374ba00a069904465a8d07971a60
Gecko: f880dae4fdbe
Version: 32.0a2 (2.0)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
See attached:
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Summary: [B2G][OAT] Smart collections are not displayed after OTA 1.3 to 2.0 → [B2G][OTA] Smart collections are not displayed after OTA 1.3 to 2.0
QAwanted added to try the steps with this url: https://aus4.mozilla.org/update/3/B2G/28.0/20140709000201/flame/en-US/aurora/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1


Also try without the smoketest profile.

Nominating for blocking 2.0 given that's collections are a core feature present in both 1.3 and 2.0 branches.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, qawanted
QA Contact: pcheng
How is this different than bug 1035272?
Flags: needinfo?(pbylenga)
This bug is 4 smart collection icons (+2 added from smoketest profile) don't appear on 2.0 when OTA from 1.3.

bug 1035272 is 4 default smart collection icons where 1 becomes a rocketship because 2.0 only has 3 default smart collection icons.
Flags: needinfo?(pbylenga)
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [systemsfe]
I reproduced the issue without pushing the profile.

I also reproduced the issue with the profile data but the second URL did not update me to the 20140709000201 build, instead it updated me to the latest.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
Flags: needinfo?(pbylenga)
Flags: needinfo?(jmitchell)
Thank you, looks like we need a way to OTA or mimic OTA to older builds in order to verify if this is a regression or not.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
In the old VH specs (https://bug989848.bugzilla.mozilla.org/attachment.cgi?id=8399672 ), it was mentionned that: "Smart collections that the user has added to their homepage will not be retained while switching [from the classic to the new homescreen]" (page 24). I remember that this choice was made because of the design of the Smart Collections.

Jaqueline, Peter: Now that the user can't switch from a homescreen to another, do we still want custom Smart Collections to be not migrated to the Vertical Homescreen?
Flags: needinfo?(pdolanjski)
Flags: needinfo?(jsavory)
(In reply to Johan Lorenzo [:jlorenzo] from comment #8)
> In the old VH specs
> (https://bug989848.bugzilla.mozilla.org/attachment.cgi?id=8399672 ), it was
> mentionned that: "Smart collections that the user has added to their
> homepage will not be retained while switching [from the classic to the new
> homescreen]" (page 24). I remember that this choice was made because of the
> design of the Smart Collections.
> 
> Jaqueline, Peter: Now that the user can't switch from a homescreen to
> another, do we still want custom Smart Collections to be not migrated to the
> Vertical Homescreen?

We discussed this in a systemsfe standup at some point recently. I believe the conclusion was that quote only applied to the case where we were going to support both homescreens in 2.0. That's changed now, so I would expect collections to be migrated to the new homescreen.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
blocking-b2g: 2.0? → 2.0+
Cristian/Amir - any ideas why 1.3 would be different than 1.4 here? Off the top of your head would you be aware of any schema changes from 1.3 -> 1.4 that we might be missing in a 1.3 -> 2.0 migration?
Flags: needinfo?(crdlc)
Flags: needinfo?(amirn)
I don't have this info, Carmen, while you are taking a look at why the entertainment icon disappears could you see this issue in your tests too? Basically to know what descriptor is been filled here https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/grid_components.js#L137? Just to have any idea what we are missing here. Thanks a lot Carmen
Flags: needinfo?(crdlc) → needinfo?(carmen.jimenezcabezas)
As far as I can remember, Collections were introduced in 1.3, and hardly any changes were made for 1.4.

$ git log --oneline --no-merges upstream/v1.3..upstream/v1.4 | grep -i collection
defd065 Bug 1009913 - [E.Me]Loading into a collection shows an empty page [r=amirn]
d26c8c3 Bug 968918 - [B2G][Everything.me][Smart Collections] Revert to Default Icon [r=ranbena]
309794a Bug 975917 - [Everything.me] Tapping homebutton while in Collection Rename mode may cause freeze [r=ranbena]
d54e619 Bug 973864 - [Everything.me] Set Collection background image as wallpaper only works on first tap [r=ranbena]
7a34c3a Bug 968963 - [E.me] Collection static apps names are not translated [r=ranbena]
8a01651 Bug 964661 - [Everything.me] Collection Suggestions list is not sorted [r=ranbena]
28a3f87 Bug 964215 - [Everything.me] Labels in Collection suggestions list do not match ones created on Homescreen [r=ranbena]
d34a22b Bug 963476 - Use a more internationally friendly collection for everything.me collection test. r=fstrugariu
501807e Bug 955887 -  [Buri] "Add Collection" wallpaper label missing
5914c09 Bug 950857 - Rename 'Collections' to 'Smart Collections' [r=ranbena]
a291b92 Revert "Revert "Bug 946724 - [e.me] Collection suggestions for unsupported languages should show English suggestions [r=ranbena]""
1afe3de Revert "Bug 946724 - [e.me] Collection suggestions for unsupported languages should show English suggestions [r=ranbena]"
084ed79 Bug 949392 - [e.me] 'Music2' removed from 'Music' collection when adding a web app [r=ranbena]
0294f58 Bug 924843 - Icons on grid do not re-arrange automatically when dragging over collections
acfc61d Bug 946724 - [e.me] Collection suggestions for unsupported languages should show English suggestions [r=ranbena]
3ac54e8 [Bug 944068] Revise collection style [r=amirn]
aa0299a Bug 946176 - [e.me][Bug] Collections Tapping issues [r=evyatar]
d38065f Bug 937536 - [e.me] Custom Collection is generated without an icon [r=ranbena, evyatron]
Flags: needinfo?(amirn)
(In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #9)
> 
> We discussed this in a systemsfe standup at some point recently. I believe
> the conclusion was that quote only applied to the case where we were going
> to support both homescreens in 2.0. That's changed now, so I would expect
> collections to be migrated to the new homescreen.

Exactly right.  Migration should work.
Flags: needinfo?(pdolanjski)
I agree as well, now that users will not be switching between the two homescreens, collections should migrate to the new vertical homescreen.
Flags: needinfo?(jsavory)
Whiteboard: [systemsfe] → [systemsfe][ETA=7/19]
Target Milestone: --- → 2.0 S6 (18july)
Assignee: nobody → carmen.jimenezcabezas
Attached patch 1037556.patch (obsolete) — Splinter Review
Well, I don't have idea how to make OTAs but I was doing some hack in my device and I saw that the bug could be here https://github.com/mozilla-b2g/gaia/commit/4ffe3053bcd36e53ad6bd362c3141ad88898221f#diff-d2f92d15c3145fadb800c6b5fbf99352R69 (bug 1028670). Could someone check this patch?
Flags: needinfo?(kgrandon)
Flags: needinfo?(jschmitt)
I'm still working on getting a proper 1.3 -> 2.0 update working. Your patch seems fine to me, though I'm not sure why a collection wouldn't have a name?
Flags: needinfo?(kgrandon)
No idea, but I had 4 predefined collections and a new one, I think "Astrology" and I saw how the migration broke there
Sorry, it failed here 

https://github.com/mozilla-b2g/gaia/blob/4ffe3053bcd36e53ad6bd362c3141ad88898221f/apps/homescreen/js/grid_components.js#L146

Maybe the predefined collections are controlled by home and ev.me data in its database has not defined those names
Duplicate of this bug: 1038298
Attached file Github pull request (obsolete) —
This patch implements:

1) Bug 1035272. Copy all collections (icon and manifest) to collection webapp.
2) Fix a problem that I saw calculating the descriptor for SC in 1.3 during the migration

This is a WIP that I would like Carmen could test and continue if she detects more problems. I think that as start point it is useful
Attachment #8456084 - Attachment is obsolete: true
Attachment #8456690 - Flags: feedback?(kgrandon)
Attachment #8456690 - Flags: feedback?(alberto.crespellperez)
See Also: → 1035272
Assignee: carmen.jimenezcabezas → crdlc
Comment on attachment 8456690 [details]
Github pull request

See github comments.
Attachment #8456690 - Flags: feedback?(alberto.crespellperez) → feedback+
Comment on attachment 8456690 [details]
Github pull request

Looks like Alberto has already provided some good feedback. I'm still haven't really looked into this too much, but I guess it does make sense. Thanks so much for putting together a patch here.
Attachment #8456690 - Flags: feedback?(kgrandon) → feedback+
Attached file Github pull request
Kevin, I made an OTA for my hamachi and the migration didn't work but with this patch works fine. I suppose that it would work for Flame too, but no idea. FYI, I removed the code to keep icons because that bug was closed as invalid
Attachment #8456841 - Flags: review?(kgrandon)
Attachment #8456690 - Attachment is obsolete: true
Comment on attachment 8456841 [details]
Github pull request

Thanks Cristian!
Attachment #8456841 - Flags: review?(kgrandon) → review+
Flags: needinfo?(carmen.jimenezcabezas)
Merged in master:

https://github.com/crdlc/gaia/commit/8b5a7eca13fbda72e4e92deb6e178f7b548cb58c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I repeated Cristian test on the Flame and it works too.
Duplicate of this bug: 1039636
See Also: → 1039646
See Also: → 1040146
Removing the NI for me based on Comment 17
Flags: needinfo?(jschmitt)
Unable to verify the fix due to bug 1040146.
Depends on: 1040146
Issue no longer reproduces, Smart Collections is now displayed after OTA on 1.3 to 2.0 and 1.3 to 2.1

Environmental Variables:
Device: Flame 2.0
Build ID: 20140729000201
Gaia: b11775fcbfe076a3fc560c2041f5b2fe1b345009
Gecko: 86b56e101512
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Environmental Variables:
Device: Flame Master
Build ID: 20140729040211
Gaia: fadfafa17f5175203b8b9457bfb95e5816f54f58
Gecko: b17cad2d1e5e
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?][lead-review+]
Flags: needinfo?(pbylenga)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?][lead-review+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.