Unreadable text in search field on about:newtab page if using dark OS theme

VERIFIED FIXED in Firefox 32

Status

()

defect
--
trivial
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: seleznev.ru, Assigned: seleznev.ru)

Tracking

unspecified
Firefox 33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 wontfix, firefox32 verified, firefox33 verified, firefox-esr31 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Posted image screenshot.png
Just look on screenshot (bright text in search field and button).

Steps to reproduce:

1. Enable dark GTK+ theme (for ex., Xfce-dusk).

2. Open about:newtab page.
Posted patch Example patch (obsolete) — Splinter Review
Just set #2e3436 color (default in gtk3 build + Adwaita theme) for GTK+ builds.
Attachment #8456033 - Flags: review?(adw)
Blocks: 962490
Comment on attachment 8456033 [details] [diff] [review]
Example patch

You should just use color:inherit here. Also, there's no reason why this should be Gtk-specific.
Attachment #8456033 - Flags: review?(adw) → review-
(In reply to Dão Gottwald [:dao] from comment #2)
> Comment on attachment 8456033 [details] [diff] [review]
> Example patch
> 
> You should just use color:inherit here.

Oops, I missed that the button has a white gradient as its background image. Since the gradient's opacity goes up to 80%, it might also make sense to use color:black here. (Although in practice it shouldn't matter since in this case color:inherit resolves to black anyway.)
OS: Linux → All
Summary: Unreadable text in search field on about:newtab page if using dark GTK+ theme → Unreadable text in search field on about:newtab page if using dark OS theme
Attachment #8456033 - Attachment is obsolete: true
(In reply to Dão Gottwald [:dao] from comment #2)
> Comment on attachment 8456033 [details] [diff] [review]
> Example patch
> 
> You should just use color:inherit here. Also, there's no reason why this
> should be Gtk-specific.

I updated example patch with account recommendations. But I am not sure that black color is good choice.
Reproduced on Firefox 31 beta 7 by using a High Contrast theme under Win 7, 64-bit.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8456064 - Flags: review+
Thanks for the patch.
Assignee: nobody → seleznev.ru
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f701765f1207
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Duplicate of this bug: 1052070
Comment on attachment 8456064 [details] [diff] [review]
Example patch 2

(normally I would ask whoever on the desktop team was involved with a change about uplift, but Dão is on PTO and I think this is trivial and safe enough that I might as well just request uplift myself)

Approval Request Comment
[Feature/regressing bug #]: bug 962490
[User impact if declined]: unreadable new tab search box on certain OS themes
[Describe test coverage new/current, TBPL]: none
[Risks and why]: none, has lots of baking on nightly and now aurora, fix is specific to the buttons and input field on the new tab page
[String/UUID change made/needed]: none

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: unreadable text in primary UI, which has caused multiple people to file bugs
User impact if declined: see above.
Fix Landed on Version: 33
Risk to taking this patch (and alternatives if risky): none, see above
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #8456064 - Flags: approval-mozilla-esr31?
Attachment #8456064 - Flags: approval-mozilla-beta?
Comment on attachment 8456064 [details] [diff] [review]
Example patch 2

Approved for beta and ESR31.
Attachment #8456064 - Flags: approval-mozilla-esr31?
Attachment #8456064 - Flags: approval-mozilla-esr31+
Attachment #8456064 - Flags: approval-mozilla-beta?
Attachment #8456064 - Flags: approval-mozilla-beta+
Keywords: verifyme
Verified fixed on Firefox Aurora, build ID:20140817004001 and Firefox 32 beta 8, build ID: 20140818191513.
The text from the search field is now visible (white) while using a dark theme.
Verified fixed on Firefox 31.1.0 ESR (buildID: 20140825060242).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.