Closed Bug 1039019 Opened 8 years ago Closed 7 years ago

Set MOZ_DISABLE_NONLOCAL_CONNECTIONS for opt B2G mochitests

Categories

(Testing :: Mochitest, defect)

defect
Not set
normal

Tracking

(b2g-v1.4 wontfix, b2g-v2.0 wontfix, b2g-v2.1 affected)

RESOLVED FIXED
mozilla34
Tracking Status
b2g-v1.4 --- wontfix
b2g-v2.0 --- wontfix
b2g-v2.1 --- affected

People

(Reporter: khuey, Assigned: emorley)

References

Details

Attachments

(1 file)

Webapps update trips this at startup, but there's probably more lingering.
Blocks: 1026958
I'm presuming you found this whilst fixing bug 1038943? The env not being passed through explains why this wasn't caught as part of bug 995417 - good spot :-)

My try run from bug 1026958:
https://tbpl.mozilla.org/?tree=Try&rev=11c7efe3e34a

Shows the following external connections...

b2g_emulator_vm try opt test mochitest-1:
marketplace.allizom.org (63.245.217.111)

b2g_emulator_vm try opt test {crashtest,reftest}:
marketplace.firefox.com (63.245.216.131)

b2g_emulator_vm try opt test {mochitest,reftest,marionette-webapi,gaia-ui-test,gaia-unit}:
inapp-pay-test.paas.allizom.org (63.245.215.73)

b2g_emulator_vm try debug test {mochitest-debug,xpcshell}:
dynamicua.cdn.mozilla.net (23.203.212.61)
Try push to see what breaks:
https://tbpl.mozilla.org/?tree=Try&rev=4152ad1ae14d
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Summary: MOZ_DISABLE_NONLOCAL_CONNECTIONS is not set on b2g → MOZ_DISABLE_NONLOCAL_CONNECTIONS is not set for B2G mochitests
Depends on: 1052016
Depends on: 1053163
Opt B2G mochitests were almost green, apart from bug 1052016:
https://tbpl.mozilla.org/?rev=4152ad1ae14d&tree=Try

My patch in bug 1052016 has a green try run (and is awaiting review):
https://tbpl.mozilla.org/?tree=Try&rev=67cdda9e6b14

Once that lands, lets at least protect ourselves from regressions in the opt tests, whilst we sort out bug 1053163 (and possibly more) affecting debug.
Attachment #8472299 - Flags: review?(nfroyd)
Full B2G try run with both the patch here and the patch from bug 1052016, just to check none of the debug tests dislike bug 1052016 on it's own:
https://tbpl.mozilla.org/?tree=Try&rev=846ea8c7a49c
Comment on attachment 8472299 [details] [diff] [review]
Set MOZ_DISABLE_NONLOCAL_CONNECTIONS for opt B2G mochitests

Review of attachment 8472299 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mochitest/runtestsb2g.py
@@ +167,5 @@
>              # empty env.
>              self.browserEnv = self.buildBrowserEnv(options, env={})
>  
> +            # B2G emulator debug tests still make external connections, so don't
> +            # pass MOZ_DISABLE_NONLOCAL_CONNECTIONS to them for now (bug 1039019).

I guess you're leaving the original bug reference here, rather than changing it to bug 1053163, because you're going to land this patch but leave this bug open until bug 1053163 lands?  If that's a correct assumption, this is fine; otherwise, I think it'd make more sense to change the bug number in the comment.
Attachment #8472299 - Flags: review?(nfroyd) → review+
(In reply to Nathan Froyd (:froydnj) from comment #6)
> I guess you're leaving the original bug reference here, rather than changing
> it to bug 1053163, because you're going to land this patch but leave this
> bug open until bug 1053163 lands?

Yeah, I know there's at least one more (dynamicua.cdn.mozilla.net; https://tbpl.mozilla.org/php/getParsedLog.php?id=45847614&tree=Try#error4) and I'm going to leave this open and hang them off of this bug.

https://hg.mozilla.org/integration/mozilla-inbound/rev/4bdf267a1b90
Keywords: leave-open
Depends on: 1053340
There's too many dependencies to easily backport this to the various B2G release branches, but I intend to at least uplift the dependencies where possible.
Blocks: 1061703
Broken the debug parts out to bug 1061703 to clean up my bugzilla-todos lists.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
No longer depends on: 1053163, 1053340
Keywords: leave-open
Resolution: --- → FIXED
Summary: MOZ_DISABLE_NONLOCAL_CONNECTIONS is not set for B2G mochitests → Set MOZ_DISABLE_NONLOCAL_CONNECTIONS for opt B2G mochitests
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.