Closed Bug 1039189 Opened 5 years ago Closed 5 years ago

[User Story] Access connectivity settings when offline in search UI

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog, b2g-v2.0 wontfix, b2g-v2.1 affected)

RESOLVED FIXED
2.1 S2 (15aug)
feature-b2g 2.1
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.1 --- affected

People

(Reporter: pdol, Assigned: arcturus)

References

Details

(Keywords: feature, Whiteboard: [ucid:System230], [ft:systemsfe])

User Story

As a user I want to be able to access my connectivity settings directly from the search UI when I am offline to make it easier to troubleshoot my lack of connectivity.

Acceptance Criteria:
1. I am able to access my device connectivity settings directly from the search UI when I do not have a WiFi or mobile data connection.

Attachments

(3 files, 1 obsolete file)

No description provided.
This bug is about implementing page 15 of specs:

https://mozilla.app.box.com/s/lbw2wzw3p4jvxs24k4sg/1/2099951272/19263814817/1
Assignee: nobody → francisco
Attached image 2014-08-05-16-13-20.png (obsolete) —
Hi,

just got a quick patch to show the settings string and the icon to launch an activity to the connectivity options in settings.

Got the icon from the system app, also realised that is going to be complicated (or I need to digg better) to return back after the activity, since it inmediately return a success when the settings is open.
Attachment #8467807 - Flags: ui-review?(epang)
Target Milestone: --- → 2.1 S2 (15aug)
Comment on attachment 8467807 [details]
2014-08-05-16-13-20.png

Hi Francisco!

This seems to be following the ixd spec but not the visual spec :).
It's close tho!

Here's a link to the visual spec 

https://mozilla.box.com/s/phhe2jydqr6nbj0heygd

You'll the offline specs on screens 8 & 9

Main changes that are needed:

1. Center icon and text
2. Capitalize 'I' in internet and 'C' in connection
3. Update settings icon to current and make sure its' 36px x 36px
4. Increase spacing between settings icon and text 12px (1.2rem on HVGA and 1.8 on flame FWVGA)

Thank for your work on this, let me know if you have any questions!
Flag me again when you've made the changes.
Attachment #8467807 - Flags: ui-review?(epang) → ui-review-
Flags: needinfo?(francisco)
(In reply to Eric Pang [:epang] from comment #3)
> Comment on attachment 8467807 [details]
> 2014-08-05-16-13-20.png
> 
> Hi Francisco!
> 
> This seems to be following the ixd spec but not the visual spec :).
> It's close tho!
> 
> Here's a link to the visual spec 
> 
> https://mozilla.box.com/s/phhe2jydqr6nbj0heygd

Perfect! I was missing the visual spec ;) ... got close!

> 
> You'll the offline specs on screens 8 & 9
> 
> Main changes that are needed:
> 
> 1. Center icon and text
> 2. Capitalize 'I' in internet and 'C' in connection
> 3. Update settings icon to current and make sure its' 36px x 36px
> 4. Increase spacing between settings icon and text 12px (1.2rem on HVGA and
> 1.8 on flame FWVGA)
> 
> Thank for your work on this, let me know if you have any questions!
> Flag me again when you've made the changes.

One last question Eric, where do I get the assets? The settings icon?
Flags: needinfo?(francisco) → needinfo?(epang)
Attached file Pointer to PR 22583
Hi,

I'm adding this for review since Kevin asked me to try to land this before I leave for PTO.

Things that are missing:
- The correct icon, couldnt find it on the assets zip file. Easy to fix in a follow up.
- The return back from settings to rocket bar is not feasible right now with current Settings web activity
- Another point: when we click on the rocket bar from the homescreen, we display the offline info, but the window manager is not display the content of the search app, not until we type. That's why it doesnt appear at the beginning unless we have something on the input.

If you prefer to solve that stuff I can do it after I join back in a week.
Attachment #8468556 - Flags: review?(kgrandon)
Comment on attachment 8468556 [details] [review]
Pointer to PR 22583

This is looking pretty good I think. I'd like at least the img as a background image and the function error to be addressed, but besides that I think we are good to go. Please re-flag me after making adjustments. Thanks!
Attachment #8468556 - Flags: review?(kgrandon)
(In reply to Francisco Jordano [:arcturus] [:francisco] (on PTO till 14th August) from comment #4)
> (In reply to Eric Pang [:epang] from comment #3)
> > Comment on attachment 8467807 [details]
> > 2014-08-05-16-13-20.png
> > 
> > Hi Francisco!
> > 
> > This seems to be following the ixd spec but not the visual spec :).
> > It's close tho!
> > 
> > Here's a link to the visual spec 
> > 
> > https://mozilla.box.com/s/phhe2jydqr6nbj0heygd
> 
> Perfect! I was missing the visual spec ;) ... got close!
> 
> > 
> > You'll the offline specs on screens 8 & 9
> > 
> > Main changes that are needed:
> > 
> > 1. Center icon and text
> > 2. Capitalize 'I' in internet and 'C' in connection
> > 3. Update settings icon to current and make sure its' 36px x 36px
> > 4. Increase spacing between settings icon and text 12px (1.2rem on HVGA and
> > 1.8 on flame FWVGA)
> > 
> > Thank for your work on this, let me know if you have any questions!
> > Flag me again when you've made the changes.
> 
> One last question Eric, where do I get the assets? The settings icon?

Hi Francisco, I was sure I did this yesterday but noticed today that my comment didn't go through...

You can find the assets here on box:
https://mozilla.box.com/s/1d71do1j3q3upy309dcx

let me know if anything else is needed!  Thanks!
Flags: needinfo?(epang)
Comment on attachment 8468556 [details] [review]
Pointer to PR 22583

Hei Kevin,

would you mind taking a look after adding your suggestions?
Attachment #8468556 - Flags: review?(kgrandon)
Attached image 2014-08-14-15-39-23.png
Hei Eric, now with the correct icon and meassure, would you mind taking a look?
Attachment #8467807 - Attachment is obsolete: true
Attachment #8472998 - Flags: ui-review?(epang)
Comment on attachment 8468556 [details] [review]
Pointer to PR 22583

Seems fine to me. Thank you!
Attachment #8468556 - Flags: review?(kgrandon) → review+
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #9)
> Created attachment 8472998 [details]
> 2014-08-14-15-39-23.png
> 
> Hei Eric, now with the correct icon and meassure, would you mind taking a
> look?

Hi Francisco, is there a reason the icon looks really blurry, looks like it might be using the 1x icon on the flame?  Can you look into this before I review?  Everything else looks good!
Please let me know if I need to create new icons assets! Thx!
Flags: needinfo?(francisco)
(In reply to Eric Pang [:epang] from comment #11)
> Hi Francisco, is there a reason the icon looks really blurry, looks like it
> might be using the 1x icon on the flame?  Can you look into this before I
> review?  Everything else looks good!
> Please let me know if I need to create new icons assets! Thx!

Hi Eric, unfortunately I can confirm that the icon used is the @1.5 for flame. Just extracted the app zip and checked that we were using the one downloaded from:

https://mozilla.app.box.com/s/1d71do1j3q3upy309dcx

Taking a look them, they already look a bit blurry to me. Do you think you can provide better icons, if so, should we land this and do a follow up, or do you prefer to land with correct icons?

Thanks!
Flags: needinfo?(francisco) → needinfo?(epang)
(In reply to Eric Pang [:epang] from comment #11)
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #9)
> > Created attachment 8472998 [details]
> > 2014-08-14-15-39-23.png
> > 
> > Hei Eric, now with the correct icon and meassure, would you mind taking a
> > look?
> 
> Hi Francisco, is there a reason the icon looks really blurry, looks like it
> might be using the 1x icon on the flame?  Can you look into this before I
> review?  Everything else looks good!
> Please let me know if I need to create new icons assets! Thx!

I've tried to make the icons a little sharper
https://mozilla.box.com/s/1d71do1j3q3upy309dcx

I think we can land and revisit if needed! Thanks!
Flags: needinfo?(epang)
Comment on attachment 8472998 [details]
2014-08-14-15-39-23.png

Can you update the icons with the ones at:
https://mozilla.box.com/s/1d71do1j3q3upy309dcx

Then we can land :)
Attachment #8472998 - Flags: ui-review?(epang) → ui-review+
Updated with the new icons.

Waiting for gaia-try to give me the green.
Finally got gaia-try green,

landed:

https://github.com/mozilla-b2g/gaia/commit/778c39b5597ea424d6a75934221265423ab3c9e7
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
apps/search/index.html
+ <span data-l10n-id="offline-message">No Internet Connection</span>

apps/search/locales/search.en-US.properties
+ offline-mesage = No Internet Connection

Notice anything wrong here (hint: typos)? Please test patches with pseudo-locales
Flags: needinfo?(francisco)
Thanks :flod,

will back it out, and commit it again without the typo
Flags: needinfo?(francisco)
Carring over the r+ from Kevin, this change is just in the strings so will merge.

Left the PR to keep track of the changes.
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.