Closed Bug 10394 Opened 21 years ago Closed 19 years ago

[feature] XPInstall has no documentation

Categories

(Developer Documentation :: General, defect, P3, critical)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dougt, Assigned: oeschger)

References

Details

The API's are different between SmartUpdate and XPInstall, hence we need new
docs.
Status: NEW → ASSIGNED
Blocks: 11020
Summary: XPInstall has no documentation → [feature] XPInstall has no documentation
Assignee: dveditz → cathleen
Status: ASSIGNED → NEW
steve, can you send us a soft copy of 4.5 doc?
Target Milestone: M11
Just got the files today from DevEdge.

I put the files up on a server---you can find all you need at
Jazz\mammoth\jarman.

What HTML editor are you going use? I'd suggest BBEdit or HomeSite.

Let me know if you have any questions about the files.
Target Milestone: M11 → M14
setting target milestone to M14.  looks like we won't be able to get some sort
of documentation by Beta1.
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Met with Steve and Ian today, and Ian is going to help taking the ownership of 
our developer docs, besides's his XUL doc responsibility!  :-) yeah!

I will start by getting our 4.5 doc, make changes that apply and send them 
towards Steve and Ian.  They'll figure out the time line for us.

This is definately out for Beta1.
Target Milestone: M14 → M16
Target Milestone: M16 → M17
Any status on these docs?
Cathleen is no longer with Netscape. I don't know if all her bugs will be 
automatically reassigned. I'll reassign this one to me, as I'm the de facto doc 
module owner.

Resetting Product to Documentation.

Here's an update: There is a tech writer (Elke Vorheis) who has been working on 
the docs. Cathleen updated the old SmartUpdate doc and provided Elke with new 
info. We should know a more exact timeline this next week, but the likelihood is 
that the doc will be completed by 6/30 or shortly thereafter. The doc will 
probably be an API reference. There's perhaps a need for an additional, separate 
guide, but we'll determine that this next week. 
Assignee: cathleen → rudman
Component: Installer: XPInstall Engine → Mozilla Developer
Product: Browser → Documentation
Target Milestone: M17 → M20
Version: other → unspecified
accepting bug...will update week of 6/26.
Status: NEW → ASSIGNED
A writer is working on the docs. She has all the new API info. She'll probably 
be done in 2-3 weeks.
steve - don't we have docs now?  
Reassigning to Ian to close out, with comment on whereabouts of the doc.

There is no project page for XPInstall at mozilla, which makes access a bit
tricky. The doc in draft form was circulated in the XPInstall newsgroup.
Assignee: rudman → oeschger
Status: ASSIGNED → NEW
David and I have submitted comments/suggestions to Ian's docs, so he's probably 
updating it.
Accepting bug, finally: XPInstall docs are in the devedge hopper. As soon as
they are published there, I will create a short list of xpinstall docs on
mozilla.org, including the "Annotated Browser XPI Install" doc I mentioned in
the xpinstall newsgroup a little while ago, the API reference, and the "Creating
Packages for Mozilla" xulnote as a starting place.

Jimmy and David: your feedback for the API was invaluable. Thanks so much for
getting me all that information and looking over the stuff I had.
Status: NEW → ASSIGNED
*** Bug 59017 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Marking fixed: XPInstall API is on devedge and linked to from mozilla.org, have
a couple of articles available from the xpinstall project page on Mozilla (also
new), and the mozilla.org splash page mentions these.
We have documentation at http://mozilla.org/projects/xpinstall/.

Marking Verified!
Status: RESOLVED → VERIFIED
Target Milestone: M20 → ---
Component: Mozilla Developer → Documentation Requests
Product: Documentation → Mozilla Developer Center
Component: Documentation Requests → Documentation
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.