Last Comment Bug 104040 - Only one page printed
: Only one page printed
Status: VERIFIED DUPLICATE of bug 85768
: verifyme
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: Trunk
: x86 Windows NT
: -- normal with 7 votes (vote)
: mozilla1.1alpha
Assigned To: Marc Attinasi
: sujay
Mentors:
http://www.alistapart.com/stories/jou...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-10 08:19 PDT by GAThrawn
Modified: 2014-04-26 03:29 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase derived from alistapart.com's old styles (27.39 KB, text/html)
2002-03-15 06:59 PST, Eric A. Meyer (dead account)
no flags Details

Description GAThrawn 2001-10-10 08:19:51 PDT
Using build 2001100503 on Windows NT4SP6 printing the page at
http://www.alistapart.com/stories/journey/5.html only prints out one page.

Steps to reproduce:
1. Visit http://www.alistapart.com/stories/journey/5.html
2. Select File -> Print...
3. Ensure that "Print Range" is set to "All" to print all pages
4. Click "OK"

Expected results:
All four pages print out.

Actual Result:
Only the first page prints.


The page layout is done entirely in CSS and it has a separate Print stylesheet
which removes nearly all CSS styling and hides the menu, the actual content is
inside a DIV named "content" (the page itself actually explains how the layout
is done and the page is arranged).
Comment 1 sujay 2001-10-10 09:08:53 PDT
I can reproduce this problem....only one page gets printed out....

cc: rods and kmcclusk.
Comment 2 David Balch 2001-10-26 03:13:44 PDT
I can reproduce this problem. (Found it on a different ALA article though,
http://www.alistapart.com/stories/infoexperience/)

Using build 2001101117 on Win2K Pro, printing to a network printer.
Comment 3 Kevin McCluskey (gone) 2001-10-26 14:04:05 PDT
Reassigning to Marc. I think this bug is a dup onf one of yours.
Comment 4 Kevin McCluskey (gone) 2001-11-09 16:50:54 PST
I can reproduce with todays cvs trunk build on WINNT, using print-preview.
Comment 5 Marc Attinasi 2002-02-04 15:33:28 PST
Floated blocks do not continue onto the next page - that is the problem here I
think.
Comment 6 GAThrawn 2002-02-05 14:34:51 PST
ALA appear to be aware of this problem and make a mention of it on their bugs
page, at http://www.alistapart.com/bugs.html

Quote from that page:


NETSCAPE 6 PRINTING BUG
An unfortunate printing bug afflicts Netscape 6.2 . Here are the symptoms: You
hit “Print.” The browser prints one page. Then it stops printing. The problem
has been reported to Netscape’s standards evangelist.
Comment 7 Kevin McCluskey (gone) 2002-02-06 14:05:27 PST
Marking nsbeta1+
Comment 8 Kevin McCluskey (gone) 2002-02-19 10:55:35 PST
nsbeta1-. Moving to Moz1.1. Engineers are overloaded with higher priority bugs.
Comment 9 GAThrawn 2002-03-11 05:44:22 PST
Just retested printing the page using 2002031005, Win 2000 Pro (from the 0.9.9
branch) succesfully printed all 4 pages from the first URL above
(http://www.alistapart.com/stories/journey/5.html) and all 3 pages from the
second URL (http://www.alistapart.com/stories/infoexperience/).

Using a networked HP Laserjet 8000.

No appears to work for me.
Comment 10 GAThrawn 2002-03-11 06:43:47 PST
s/No appears to work for me./All now appear to work for me/
Comment 11 sujay 2002-03-11 08:01:14 PST
marking WFM per comments.
Comment 12 sujay 2002-03-11 09:50:47 PST
verified.
Comment 13 Eric A. Meyer (dead account) 2002-03-15 06:46:06 PST
The test URLs appear to work because the site's stylesheets have been changed to
un-float the content DIV when printing, and thus avoid this particular bug.  If
the bug has been fixed, you won't be able to prove it using alistapart.com any
more.  See http://www.alistapart.com/bugs.html for more information.

I'm reopening this bug because I see no evidence of a patch that fixed it, and
the pages used to test it are no longer relevant to this report.  I will create
a testcase based on the old ALA styles and attach it to this bug.
Comment 14 Eric A. Meyer (dead account) 2002-03-15 06:59:56 PST
Created attachment 74329 [details]
Testcase derived from alistapart.com's old styles

This testcase is a version of "To Hell With Bad Browsers" with the old
print-media stylesheet embedded instead of linked.  The all-media stylesheet,
which is the one that floats the #content DIV, is also embedded to prevent
future "silent" changes on alistapart.com creating the appearance of a fix.

In 2002031106/Mac, this testcase resulted in only a single page being printed.
Comment 15 Ben Guthrie 2002-03-15 07:46:45 PST
confirming for NT

2002031503/NT  using test attachment 74329 [details] only one page prints - in print
preview it only shows "page 1"
Comment 16 Boris Zbarsky [:bz] (Out June 25-July 6) 2002-03-15 09:39:10 PST
Duplicate of "[FLOAT] [PRINT]Floated elements that do not fit on a page are not
continued to the next page when printed." (per comment 5 and comment 13)

*** This bug has been marked as a duplicate of 85768 ***
Comment 17 sujay 2002-03-15 15:03:06 PST
v
Comment 18 Peter K. Sheerin 2002-09-16 15:53:19 PDT
This bug appears to have been fixed (attachment print previews OK in 200209608,
and  also using a test case of mine), but I've just discovered a page design on
our site that exhibits the same behavior (only first page prints), but it
doesn't use any floats--it's an old table-based layout that prints OK in IE.

http://www.cadenceweb.com/newsletter/aec/0802_1.html

Both printing and print preview show only the first page of this and all similar
documents on our site that I have tested. I can verify this behavior on
200209608 on WinXP and on 2002090908 on MacOS 9.1.

Shall I open this as a new bug? All of the other "one page prints" bugs seem to
be specific to properties that are not present in this design (frameset,
left-aligned table, floated div), and some of those have been marked fixed/resolved.
Comment 19 Boris Zbarsky [:bz] (Out June 25-July 6) 2002-09-20 09:30:55 PDT
Yes, open a new bug please.
Comment 20 Naresh 2008-04-01 05:13:55 PDT
(In reply to comment #0)
> Using build 2001100503 on Windows NT4SP6 printing the page at
> http://www.alistapart.com/stories/journey/5.html only prints out one page.
> 
> Steps to reproduce:
> 1. Visit http://www.alistapart.com/stories/journey/5.html
> 2. Select File -> Print...
> 3. Ensure that "Print Range" is set to "All" to print all pages
> 4. Click "OK"
> 
> Expected results:
> All four pages print out.
> 
> Actual Result:
> Only the first page prints.
> 
> 
> The page layout is done entirely in CSS and it has a separate Print stylesheet
> which removes nearly all CSS styling and hides the menu, the actual content is
> inside a DIV named "content" (the page itself actually explains how the layout
> is done and the page is arranged).

I could solve for myself, byadding position: relative in the div tag. It was working fine for me.
Comment 21 Johnny Benson 2010-08-19 13:08:54 PDT
This is still a problem for me. 

Firefox (Mac OSX) still prints only the first page of floated elements.

Is there any new information or better practices surrounding this other than

float: none !important

?

Thanks
Comment 22 Boris Zbarsky [:bz] (Out June 25-July 6) 2010-08-22 22:58:57 PDT
Johnny, try Firefox 4 beta 4 once that comes out?  Float printing was just rewritten recently (see bug 563584).
Comment 23 Teancum 2010-12-27 10:49:27 PST
A more recent version of this bug is documented at the following link:

https://bugzilla.mozilla.org/show_bug.cgi?id=258397

Note You need to log in before you can comment on or make changes to this bug.