Closed Bug 85768 Opened 19 years ago Closed 17 years ago

[FLOAT] [PRINT]Floated elements that do not fit on a page are not continued to the next page when printed.

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
mozilla1.1alpha

People

(Reporter: attinasi, Assigned: alexsavulov)

References

Details

Attachments

(1 file)

When printing a page, an element that is floated will not be continued on the
next page if it cannot fit on the current page. If the element is not floated it
is continued correctly on the next page. The problem seems top be in
ReflowFloater, which does not seem to handle incomplete status from a block's
reflow.
Blocks: 74738
Trying for 0.9.2
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2
Not going to make the 0.9.2 cutoff - moving to 0.9.3

(note: blocked 0.9.2 bug 74738 has temporary hack that is not dependant on this)
Target Milestone: mozilla0.9.2 → mozilla0.9.3
*** Bug 80338 has been marked as a duplicate of this bug. ***
*** Must remove the hack to html.css that was put in for bug 74738 when this is
fixed. ***
Target Milestone: mozilla0.9.3 → mozilla0.9.4
Target Milestone: mozilla0.9.4 → mozilla1.0
Keywords: mozilla1.0
Target Milestone: mozilla1.0 → mozilla0.9.8
Summary: Floated elements that do not fit on a page are not continued to the next page when printed. → [FLOAT] [PRINT]Floated elements that do not fit on a page are not continued to the next page when printed.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
[FLOAT] bugs to Alex :)
Assignee: attinasi → alexsavulov
Status: ASSIGNED → NEW
retargeting
Target Milestone: mozilla0.9.9 → mozilla1.0
Moving to Mozilla1.1. Engineers are overloaded with higher priority bugs.
Target Milestone: mozilla1.0 → mozilla1.1
*** Bug 104040 has been marked as a duplicate of this bug. ***
Just a note: Eric Meyer noted in bug 153785 that this bug and that one might be
dups.  153785 is fixed now, and I note that this bug's testcase WFM in the 1.1
beta milestone (build 2002072204 PC/Win98).

I'm wondering if the fix there has fixed this bug.  Unless someone can still
reproduce it, of course....
chris:

can you test this issue please when you get a chance? at home i don't ahev a
printer so i cannot verify printer bugs. thanx!
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a)
Gecko/20020611

this should have been fixed by some recent floaters/printing fixes i think.
WFM 2003031308, Windows 2000, marking as WORKSFORME since several people also
verified this in the last comments.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.