If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bugzilla Helper search freezes browser

VERIFIED DUPLICATE of bug 77460

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 77460
16 years ago
13 years ago

People

(Reporter: Jurgen Botz, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011010
BuildID:    2001101008

I was trying to report a different bug and went to the bugzilla helper, 
picked "Mail and News" for product, then "Mail window front end" for component,
then clicked "See bugs in this component.  That page came up in new window and
listed bugs but also said near top that it was too long "for mozilla's little
brain to handle".  The sidebar opened to "Search Results", but was empty.  At
this point the browser froze and top showed it eating CPU until I killed it.

Reproducible: Always
Steps to Reproduce:
1.see above.  I tried it twice with same result.
2.
3.
WFM 2001100803 on Win2k. 

Reporter: Does a fresh profile allaviate your issue? You can manage profiles
with "mozilla -profilemanager".
Summary: bugzilla search freezes browser → Bugzilla Helper search freezes browser

Comment 2

16 years ago
Rendering a long list of bugs will take a long time.  Additionally, if the
search sidebar is open (... or closed, bug 91168), it will attempt some
horrendous earth-shattering calculation on the resulting list of bugs -- this is
bug 77460.

Recently, there had been a "regression" that broke the search sidebar, for which
I was exceedingly grateful.  Maybe it's come back?

In any case, it's likely that mozilla would have unfrozen eventually, just after
many seconds of thought.

Comment 3

16 years ago
Agreed - dup of bug 77460. The search sidebar was not updated for a while
because the feature was broken, fixed with recent checkin for bug 103415.

You can disable the sidebar search (to avoid freezes), see comments in bug 77460.
In the latest CVS build, Linux, disabling it now seems to work as desired.


*** This bug has been marked as a duplicate of 77460 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.