Closed Bug 1041244 Opened 8 years ago Closed 8 years ago

Segfault on GMP plugin communication attempt

Categories

(Core :: WebRTC, defect)

33 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1041226

People

(Reporter: drno, Unassigned)

References

(Blocks 1 open bug)

Details

I compiled m-c with latest changeset 195016:1e7f2af8d929 plus the patch from bug 1041080 locally.
After making one H264 call successfully on webrtc-landing/pc_test.html I disabled the H264 plugin. Made another call attempt. Verified that it failed. Then I enabled and disabled the plugin a couple of times.
Finally I enabled it again and tried another H264 call and got this seg fault crash as result:
https://crash-stats.mozilla.com/report/index/5b834299-634b-4e3a-8c7b-17ad92140720
See Also: → 1041226
Console output before the crash:

--DOMWINDOW == 27 (0x135567800) [pid = 77773] [serial = 53] [outer = 0x1347ebc00] [url = about:blank]
--DOMWINDOW == 26 (0x135564400) [pid = 77773] [serial = 51] [outer = 0x135042000] [url = about:blank]
--DOMWINDOW == 25 (0x135042000) [pid = 77773] [serial = 50] [outer = 0x0] [url = about:blank]
[77773] WARNING: Adding track to StreamBuffer that should have no more tracks: file /Users/nohlmeier/src/mozilla-central/content/media/StreamBuffer.h, line 249
[77773] WARNING: 'NS_FAILED(branch->GetBoolPref("media.video.test_latency", &mVideoLatencyTestEnable))', file /Users/nohlmeier/src/mozilla-central/media/webrtc/signaling/src/media-conduit/VideoConduit.cpp, line 291
[77773] WARNING: 'NS_FAILED(branch->GetBoolPref("media.video.test_latency", &mVideoLatencyTestEnable))', file /Users/nohlmeier/src/mozilla-central/media/webrtc/signaling/src/media-conduit/VideoConduit.cpp, line 291
[77773] WARNING: Adding track to StreamBuffer that should have no more tracks: file /Users/nohlmeier/src/mozilla-central/content/media/StreamBuffer.h, line 249
[77794] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /Users/nohlmeier/src/mozilla-central/xpcom/base/nsTraceRefcnt.cpp, line 145
[77794] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /Users/nohlmeier/src/mozilla-central/xpcom/base/nsTraceRefcnt.cpp, line 145
[77773] WARNING: 'NS_FAILED(branch->GetBoolPref("media.video.test_latency", &mVideoLatencyTestEnable))', file /Users/nohlmeier/src/mozilla-central/media/webrtc/signaling/src/media-conduit/VideoConduit.cpp, line 291
[77773] WARNING: Adding track to StreamBuffer that should have no more tracks: file /Users/nohlmeier/src/mozilla-central/content/media/StreamBuffer.h, line 249
[77773] WARNING: 'NS_FAILED(branch->GetBoolPref("media.video.test_latency", &mVideoLatencyTestEnable))', file /Users/nohlmeier/src/mozilla-central/media/webrtc/signaling/src/media-conduit/VideoConduit.cpp, line 291
JavaScript error: , line 0: 'play' called on an object that does not implement interface HTMLMediaElement.
[77794] WARNING: Abnormal shutdown of GMP process!: file /Users/nohlmeier/src/mozilla-central/content/media/gmp/GMPChild.cpp, line 135
Georg -- The info on this bug may be useful in debugging Bug 1041226
I was able to reproduce this one more time.
See Also: → 1041402
Version: Trunk → 33 Branch
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041226
You need to log in before you can comment on or make changes to this bug.