Closed Bug 1041402 Opened 6 years ago Closed 6 years ago

Crash in GMP plugin code

Categories

(Core :: WebRTC, defect)

33 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1041232

People

(Reporter: drno, Assigned: jesup)

References

(Blocks 1 open bug)

Details

Re-enabled previously disabled OpenH264 plugin. Opened pc_test.html on webrtc-landing and got this EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE crash: https://crash-stats.mozilla.com/report/index/7e17b2c1-1fed-478b-849c-6b3392140720
Does this happen every time or was it a one-time thing?  I have been unable to duplicate this one, but GMP does crash like this if you disable the plugin while it is running in another tab.
Nils -- See Comment 1 from Ehugg.  This appears to be a dup of Bug 1041232.  (Randell's working on the solution to that bug now.)
Flags: needinfo?(drno)
Whiteboard: [openh264-uplift]
It was a one time thing.
But in the attempt to reproduce it I encountered bug 1042348 (again a one time thing).
I'll try to reproduce more often.

Is there a delay between disabling the plugin and being able to safely place a WebRTC call without crashes? I think there should not, but it sounds like I have to wait X seconds before the plugin is properly turned off.
Flags: needinfo?(drno)
Sorry can't reproduce, because I can no longer place a single H264 call, because it keeps crashing in bug 1042348
Ok, I'm assigning to Randell to investigate and try to repro after Bug 1042348 is resolved.  With a little luck, this will turn out to be a dupe of Bug 1042348.
Assignee: nobody → rjesup
Can't be 100% sure, but it does appear to be a dup of 1041232
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041232
Whiteboard: [openh264-uplift]
You need to log in before you can comment on or make changes to this bug.