TEST-UNEXPECTED-FAIL | mozmill/content-tabs/test-install-xpi.js | test-install-xpi.js::test_install_corrupt_xpi + test-install-xpi.js::test_install_xpi_offer + test-install-xpi.js::test_xpinstall_disabled + test-install-xpi.js::test_xpinstall_actually_i

RESOLVED FIXED in Thunderbird 34.0

Status

Thunderbird
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

({intermittent-failure, regression})

Trunk
Thunderbird 34.0
intermittent-failure, regression

Thunderbird Tracking Flags

(thunderbird33 fixed, thunderbird34 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Step Pass: {"function": "controller.click()"}
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]'[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/amWebInstallListener.js :: extWebInstallListener_onWebInstallBlocked :: line 302"  data: yes]
************************************************************
Test Failure: Timeout waiting for alert
TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_install_corrupt_xpi
TEST-START | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test_install_xpi_offer
Step Pass: {"function": "controller.click()"}
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]'[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/amWebInstallListener.js :: extWebInstallListener_onWebInstallBlocked :: line 302"  data: yes]
************************************************************
Test Failure: Timeout waiting for alert
TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_install_xpi_offer
TEST-START | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test_xpinstall_disabled
Step Pass: {"function": "controller.click()"}
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]'[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/amWebInstallListener.js :: extWebInstallListener_onWebInstallDisabled :: line 284"  data: yes]
************************************************************
Test Failure: Timeout waiting for alert
TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_xpinstall_disabled
TEST-START | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test_xpinstall_actually_install
Step Pass: {"function": "controller.click()"}
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]'[JavaScript Error: "win is undefined" {file: "chrome://messenger/content/specialTabs.js" line: 1235}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/amWebInstallListener.js :: extWebInstallListener_onWebInstallDisabled :: line 284"  data: yes]
************************************************************

SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_install_corrupt_xpi
  EXCEPTION: Timeout waiting for alert
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
       MozMillController.prototype.waitFor controller.js:685 3
       AlertWatcher.waitForAlert test-install-xpi.js:37 1
       click_install_link_and_wait_for_alert test-install-xpi.js:83 3
       test_install_corrupt_xpi test-install-xpi.js:102 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_install_xpi_offer
  EXCEPTION: Timeout waiting for alert
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
       MozMillController.prototype.waitFor controller.js:685 3
       AlertWatcher.waitForAlert test-install-xpi.js:37 1
       click_install_link_and_wait_for_alert test-install-xpi.js:83 3
       test_install_xpi_offer test-install-xpi.js:120 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_xpinstall_disabled
  EXCEPTION: Timeout waiting for alert
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
       MozMillController.prototype.waitFor controller.js:685 3
       AlertWatcher.waitForAlert test-install-xpi.js:37 1
       click_install_link_and_wait_for_alert test-install-xpi.js:83 3
       test_xpinstall_disabled test-install-xpi.js:137 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-tabs\test-install-xpi.js | test-install-xpi.js::test_xpinstall_actually_install
  EXCEPTION: Timeout waiting for alert
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
       MozMillController.prototype.waitFor controller.js:685 3
       AlertWatcher.waitForAlert test-install-xpi.js:37 1
       click_install_link_and_wait_for_alert test-install-xpi.js:83 3
       test_xpinstall_actually_install test-install-xpi.js:144 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-PASS | test-install-xpi.js::teardownModule

First(?) seen in https://tbpl.mozilla.org/?tree=Thunderbird-Trunk&rev=dd587f8d4d97 - fallout from bug 952201 - http://hg.mozilla.org/mozilla-central/rev/53f37bbfd7ab

I guess I can look into this, if nobody's on it already...
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 6

4 years ago
Created attachment 8460155 [details] [diff] [review]
bug1041475_xpi_test_fail.patch

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=ccc38975800e looks good

This fixes the test failure, and I think making xpi install in specialTabs work with e10s is out of scope for this bug.
Attachment #8460155 - Flags: review?(mconley)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 8460155 [details] [diff] [review]
bug1041475_xpi_test_fail.patch

Thanks Magnus!
Attachment #8460155 - Flags: review?(mconley) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 20

4 years ago
https://hg.mozilla.org/comm-central/rev/42281e0027ee
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
Does this need uplift to c-a?
Flags: needinfo?(mkmelin+mozilla)
(Assignee)

Comment 22

4 years ago
Comment on attachment 8460155 [details] [diff] [review]
bug1041475_xpi_test_fail.patch

[Approval Request Comment]
Regression caused by (bug #): bug 952201 
User impact if declined: can't install xpis in specialTabs
Testing completed (on c-c, etc.): tests pass on trunk
Risk to taking this patch (and alternatives if risky): very low
Attachment #8460155 - Flags: approval-comm-aurora?
Flags: needinfo?(mkmelin+mozilla)
Attachment #8460155 - Flags: approval-comm-aurora? → approval-comm-aurora+
status-thunderbird34: --- → fixed
You need to log in before you can comment on or make changes to this bug.