Last Comment Bug 1041964 - Indicate that a comment is required when selecting a value which has an auto-comment configured
: Indicate that a comment is required when selecting a value which has an auto-...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Extensions: TrackingFlags (show other bugs)
: Production
: All All
-- enhancement (vote)
: ---
Assigned To: Byron Jones ‹:glob›
:
:
Mentors:
: 1051186 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-22 01:43 PDT by Sylvestre Ledru [:sylvestre]
Modified: 2014-08-11 22:45 PDT (History)
4 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
1041964_1.patch (1.58 KB, patch)
2014-08-05 00:22 PDT, Byron Jones ‹:glob›
dkl: review-
Details | Diff | Splinter Review
1041964_2.patch (1.70 KB, patch)
2014-08-10 22:13 PDT, Byron Jones ‹:glob›
dkl: review+
Details | Diff | Splinter Review

Description User image Sylvestre Ledru [:sylvestre] 2014-07-22 01:43:09 PDT
It would be nice if we could have an automatic focus to the regular bugzilla textarea when selecting relnotes? or tracking-firefoxXX? are used.

Please consider that we may want to disable this feature if it is a pain for users (I guess people don't like when the focus changes).
Comment 1 User image Sylvestre Ledru [:sylvestre] 2014-07-24 01:31:04 PDT
Or, maybe a better solution, instead of changing the focus, maybe open a new textarea close to tracking flag to make sure that the user sees it (without the focus change)
Comment 2 User image Byron Jones ‹:glob› 2014-07-24 06:40:50 PDT
(In reply to Sylvestre Ledru [:sylvestre] from comment #1)
> Or, maybe a better solution, instead of changing the focus, maybe open a new
> textarea close to tracking flag to make sure that the user sees it (without
> the focus change)

i think that focusing and scrolling the textarea is a better solution than creating/moving the comment textarea.


another option which may be simpler is displaying a short notification next to the flag..

  [ relnotes-firefox? ] (comment required)

clicking on the notification scrolls the comment textarea into view and focuses is.
Comment 3 User image Sylvestre Ledru [:sylvestre] 2014-07-24 06:43:30 PDT
Yeh, you like better your proposal :)
Comment 4 User image Sylvestre Ledru [:sylvestre] 2014-08-04 06:03:00 PDT
FYI, most of the people don't see the autocomment. This gives stuff like:
https://bugzilla.mozilla.org/show_bug.cgi?id=1048099#c1
Comment 5 User image Byron Jones ‹:glob› 2014-08-05 00:22:38 PDT
Created attachment 8467583 [details] [diff] [review]
1041964_1.patch
Comment 6 User image David Lawrence [:dkl] 2014-08-05 14:23:30 PDT
Comment on attachment 8467583 [details] [diff] [review]
1041964_1.patch

Review of attachment 8467583 [details] [diff] [review]:
-----------------------------------------------------------------

::: extensions/TrackingFlags/web/js/tracking_flags.js
@@ +52,4 @@
>          return;
> +    }
> +    // create "comment required"
> +    var span = document.createElement('span');

Need to check to see if this span is already present, otherwise if the user first selects one value with a required comment, but then selects another, it keeps adding another (comment required) each time.
Comment 7 User image Sylvestre Ledru [:sylvestre] 2014-08-09 02:25:45 PDT
*** Bug 1051186 has been marked as a duplicate of this bug. ***
Comment 8 User image Byron Jones ‹:glob› 2014-08-10 22:13:05 PDT
Created attachment 8470631 [details] [diff] [review]
1041964_2.patch
Comment 9 User image David Lawrence [:dkl] 2014-08-11 09:58:27 PDT
Comment on attachment 8470631 [details] [diff] [review]
1041964_2.patch

Review of attachment 8470631 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Comment 10 User image Byron Jones ‹:glob› 2014-08-11 22:44:20 PDT
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   cf5c164..2957d62  master -> master

Note You need to log in before you can comment on or make changes to this bug.