Closed Bug 1042012 Opened 5 years ago Closed 5 years ago

[Rocketbar] View URL activity should be handled by the system app

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1)

RESOLVED FIXED
2.1 S2 (15aug)
feature-b2g 2.1

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
vingtetun
: review+
yurenju
: review+
qdot
: review+
Details | Review
Once we have browser chrome, we can enable the manifest property in the system app and remove it from the browser manifest. When this is done we should be able to use activities again.
Assignee: nobody → kgrandon
Duplicate of this bug: 1048313
Whiteboard: [systemsfe]
Summary: [Search] Use activities for opening URLs → [Rocketbar View URL activity should be handled by the system app
Target Milestone: --- → 2.1 S6 (10oct)
Summary: [Rocketbar View URL activity should be handled by the system app → [Rocketbar] View URL activity should be handled by the system app
Attached file Github pull request
Comment on attachment 8469541 [details] [review]
Github pull request

Hey guys, I think this would be a next good step towards enabling the system browser. Right now using the phone on trunk is a bit annoying because it's a mix of the old browser, and the system browser. Moving activities over to use the system browser would make the experience a lot more fluid. And folks can still access the old browser if they need to.

R? on Vivien for the system app.
R? on Yuren for build changes.
R? on Kyle because I am changing the browser app here again.

Kyle - the changes to the browser app do nothing except delete code. We definitely need to remove the activities part, but let me know if this causes you headaches.
Attachment #8469541 - Flags: review?(yurenju.mozilla)
Attachment #8469541 - Flags: review?(kyle)
Attachment #8469541 - Flags: review?(21)
Comment on attachment 8469541 [details] [review]
Github pull request

Fine with me. Thanks for heads up.
Attachment #8469541 - Flags: review?(kyle) → review+
Comment on attachment 8469541 [details] [review]
Github pull request

r=yurenju if document on MDN for HAIDA flag[1] is marked as deprecated on 2.1.

[1] https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/make_options_reference#Haida_features
Attachment #8469541 - Flags: review?(yurenju.mozilla) → review+
Comment on attachment 8469541 [details] [review]
Github pull request

LGTM. Let's use our nice new system browser.
Attachment #8469541 - Flags: review?(21) → review+
Chris - I would like to deprecate the HAIDA flag docs on MDN (see comment 5). Is there any preferred way of doing this? Being that it was mainly only used by engineers, I think deleting the section is fine.

Let me know if you're ok with this, or feel free to delete/update it yourself. Thanks!
Flags: needinfo?(cmills)
Thanks guys. This is now landed in master and we'll make sure the MDN docs are updated as well: 

https://github.com/mozilla-b2g/gaia/commit/901c6e1168e787a1c4788cbabe1fe7786ede61b3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
feature-b2g: --- → 2.1
Target Milestone: 2.1 S6 (10oct) → 2.1 S2 (15aug)
(In reply to Kevin Grandon :kgrandon from comment #7)
> Chris - I would like to deprecate the HAIDA flag docs on MDN (see comment
> 5). Is there any preferred way of doing this? Being that it was mainly only
> used by engineers, I think deleting the section is fine.
> 
> Let me know if you're ok with this, or feel free to delete/update it
> yourself. Thanks!

Boom, it's gone.

Although it does make me wonder if it'd be a better idea for me to create a "Deprecated make options" section at the bottom of the doc to record such historic stuff, just in case people are interested. What do you think?
Flags: needinfo?(cmills)
Perhaps having a deprecated flag for options for a release or two might make sense. I'm not sure if there's value in keeping these options around until the end of time.
I think we'll leave it for now actually; there may be others that are more of a grey area, but in this case there isn't much value in enabling haida stuff when it is now fully available in a later version.
You need to log in before you can comment on or make changes to this bug.