Change Android 2.2 builds to be called Android 2.3 builds

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kmoir, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

3 years ago
This will mean changes in our configs, possibly tbpl too.
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
(Assignee)

Comment 1

3 years ago
will take care of this is in bug 1042835
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042835
(Assignee)

Comment 2

3 years ago
reopening because Callek requested that name changes occur in a separate bug
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

3 years ago
Depends on: 1042835
(Assignee)

Comment 3

3 years ago
Created attachment 8463961 [details] [diff] [review]
bug1042838.patch
(Assignee)

Comment 4

3 years ago
Created attachment 8463995 [details] [diff] [review]
bug1042835tbpl.patch
(Assignee)

Comment 5

3 years ago
Created attachment 8464054 [details] [diff] [review]
bug1042838.patch

wrong file attached first time
Attachment #8463961 - Attachment is obsolete: true
Comment on attachment 8463995 [details] [diff] [review]
bug1042835tbpl.patch

Review of attachment 8463995 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/Config.js
@@ +350,5 @@
>      "windowsxp": "Windows XP",
>      "windows7-32": "Windows 7",
>      "windows8-32": "Windows 8",
>      "windows2012-64": "Windows 2012 x64",
> +    "android-2-2-armv6": "Android 2.3 Armv6",

What's the reason for this? We're still going to run 2.2 Armv6 jobs on esr31, right?
(Assignee)

Comment 7

3 years ago
re: comment #6

Yes.  But to clarify, blassey asked that all Android 2.2 jobs be named Android 2.3 in the mobile meeting last Wednesday.  So my understanding is that he wanted them all renamed. If this will cause problems on tbpl I can rework the patch.
12:27:44 PM - RyanVM: blassey: do you have any objections to leaving Android jobs on esr31 labeled as 2.2?
12:28:15 PM - blassey: no
(Assignee)

Comment 9

3 years ago
Looking at this again, I don't see how we can keep builds named as 2.2 on ESR but call them 2.3 on other branches. So I think we'll just leave them as 2.2 for now and when we get rid of it on ESR we can rename it all.
(Assignee)

Comment 10

3 years ago
from #releng

RyanVM|sheriffduty	kmoir: let's just call the builds 2.3 and we can live with it on esr31
RyanVM|sheriffduty	the tests will still say the right thing
(Assignee)

Comment 11

3 years ago
Created attachment 8464121 [details] [diff] [review]
bug1042838-2.patch

Rename builds but not tests as per RyanVM
Attachment #8464054 - Attachment is obsolete: true
Attachment #8464121 - Flags: review?(bugspam.Callek)
Comment on attachment 8464121 [details] [diff] [review]
bug1042838-2.patch

Review of attachment 8464121 [details] [diff] [review]:
-----------------------------------------------------------------

This review is on the assumption that the places we do builder name matching will get taken care of. :-)
Attachment #8464121 - Flags: review?(bugspam.Callek) → review+
Merged to production, and deployed.
(Assignee)

Comment 14

3 years ago
verified on tbpl
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.