Closed Bug 1042865 Opened 5 years ago Closed 5 years ago

compound clipPaths not animating

Categories

(Core :: SVG, defect)

30 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: david.dailey, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

http://srufaculty.sru.edu/david.dailey/svg/newstuff/clipPath4.svg

Renders properly in IE, Chrome, Safari, old Opera. Third clip is not rendered in FF. Animation doesn't run in FF. I believe this worked in older versions of FF.


Actual results:

The animation shows evidence of slight movement when SVG is clicked in FF. In other browsers, clicking starts or stops the animation.
(In reply to david.dailey from comment #0)
> Renders properly in IE, Chrome, Safari, old Opera. Third clip is not
> rendered in FF.

Can you be more specific (and perhaps attach a screenshot) for this part?  The initial rendering looks the same in Firefox and Chrome, for me.  (In both browsers, I see three vertical stripes, a horizontal bar, and three stars with faces behind them -- and the right two stars are clipped at the edge of the horizontal bar)

(It might be worth tracking this part in its own bug, if this ends up being platform-specific, and leaving this bug to be about the failure-to-animate.)

> Animation doesn't run in FF.

I can confirm this, in Firefox Nightly. (after clicking, which is what's supposed to start the animation)

> I believe this worked in older
> versions of FF.

Confirmed. Brief local testing shows that it animates correctly (after clicking) in Firefox 21, but not in Firefox 29.
Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0

Adding regressionwindow-wanted to request a narrower regression window.

> The animation shows evidence of slight movement when SVG is clicked in FF.

Yeah -- more generally, the animation plays a few frames when you do anything that forces a repaint -- e.g. clicking the title-bar or switching tabs, or hitting print-screen key.  So, this seems like an invalidation bug.
Nevermind, I ended up narrowing the range myself.

I get:
{
Last good revision: 05533d50f2f7 (2013-04-29)
First bad revision: dd0c611a0a27 (2013-04-30)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=05533d50f2f7&tochange=dd0c611a0a27
}

...which includes http://hg.mozilla.org/mozilla-central/rev/dc6bd7ea66f6 :
Jonathan Watt — Bug 839865 - Stop calling nsSVGUtils::InvalidateBounds for SVG transform changes, and use DLBI instead. r=mattwoodrow

...which is almost certainly responsible, given that this seems to be an invalidation bug.
Blocks: 839865
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: compound clipPaths not rendering → compound clipPaths not animating
In Firefox 31, only two stars show up -- the two at left.

D
That's a separate issue. Perhaps you could create a non-animated testcase with just that third clipPath in it and create a new bug for that.
(I see all three stars in Firefox 31 on Ubuntu Linux, FWIW. That issue must be platform and/or hardware-dependent.)
I have reported the non-display of the third star, in a simplified testcase (Bug 1044191 ) as per Robert's suggestion above (comment 4).
Animation was fixed by bug 975757, though the third star is still missing.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 975757
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.