[Flatfish][Settings] Need to remove the Manage Ringtones button from Sound page.

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: eva.chen.fx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][TCP])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8461447 [details]
Manage Ringtones.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Tap on 'Settings' and tap 'Sound'
2. Select 'Manage Sounds' --> 'Manage Ringtones'
<ISSUE> Flatfish doesn't support telephony. We should remove the 'Manage Ringtones button' from Sound page.
-----------------------------------------------
Environment Informations:
DUT: Flatfish
Gaia: e391c554 (2014-07-24 03:48:49)
B2G: 2.1.0.0-prerelease
Platform version : 33.0a1
(Reporter)

Updated

4 years ago
Blocks: 903304
Whiteboard: [Flatfish][TCP]

Comment 1

4 years ago
hmm.. this is an interesting one. It can't be covered by querying if API exists at rum-time to hide the menu. This setting doesn't use any telephony API call but it actually depends on telephony feature.
@chens, I remember we had a offline discussion on this kind of issues, did we have a conclusion?
Flags: needinfo?(shchen)
Conclusion is we keep existing checking mechanism as is and change nothing.

Under current design, we can still check if telephony API available, but it's vague.
Another approach we can do is remove ringtones app from applist, and check if ringtones app exist in settings app, like ftu_launcher does in system app. But this will raise another issue, ringtones app include ringtones and alerttones, notice alerttones is required by something not telephony apps.

So maybe a follow-up discussion on how to properly expose these info is still needed.
Flags: needinfo?(shchen)
I think 'Manage Ringtones' button here doesn't only represent manage ringtone for incoming calls, also it can be used as manage other tones like alerts. Thus I think removing this button is not an appropriate approach, and I would consider this one as invalid and close it.
Flags: needinfo?(ehung)

Comment 4

4 years ago
(In reply to Sherman Chen [:chens] from comment #3)
> I think 'Manage Ringtones' button here doesn't only represent manage
> ringtone for incoming calls, also it can be used as manage other tones like
> alerts. Thus I think removing this button is not an appropriate approach,
> and I would consider this one as invalid and close it.

That's correct, and in 2.1, we're clearer about this: the button is called "Manage Tones", and it shows both ringtones and alert tones in the list.

Resolving this as INVALID, but I'm certainly open to other ways to improve things if the work in 2.1 isn't enough.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Clearing ni since it's resolved.
Flags: needinfo?(ehung)
You need to log in before you can comment on or make changes to this bug.