Closed Bug 1043420 Opened 6 years ago Closed 6 years ago

Mochitest log.error no longer includes "ERROR"

Categories

(Testing :: Mochitest, defect)

defect
Not set
normal

Tracking

(firefox33 fixed, firefox34 fixed)

RESOLVED FIXED
mozilla34
Tracking Status
firefox33 --- fixed
firefox34 --- fixed

People

(Reporter: ted, Assigned: akachkach)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

There are some error-handling code paths in Mochitest that use log.error. Since the structured logging changes, these get printed as INFO, which means they don't get highlighted on TBPL, and also it's confusing.

Sample (from a patch I'm working on):
log.error('Could not find path to gmp-fake plugin!')

Output produced:
0 INFO Could not find path to gmp-fake plugin!
Assignee: nobody → akachkach
Ah, I guess this might be the cause of at least one of bug 1043428 and bug 1043433.
Blocks: 778688
This should do it. (Note that this just for the log level shown after the line number, the one shown before it is added by mozharness).

Example output:

1888 WARNING Warning: webapprt_indexeddb.html from manifest /Users/akachkach/workspace/gecko-dev/obj-x86_64-apple-darwin13.3.0/_tests/testing/mochitest/tests/webapprt/test/content/mochitest.ini is not a valid test
1889 INFO SUITE-START | Running 3649 tests
1890 INFO runtests.py | Running tests: start.

1891 INFO runtests.py | Application pid: 73462
1892 ERROR EXAMPLE ERROR
1893 INFO -*- Webapps.jsm : Saving /var/folders/d8/dn7q5bvx0r3_qwzh8nqy2sr40000gn/T/tmpapUEoa.mozrunner/webapps/webapps.json
Attachment #8461630 - Flags: review?(ted)
Comment on attachment 8461630 [details] [diff] [review]
0001-Bug-1043420-Use-actual-log-level-in-mochitest-logs-i.patch

Review of attachment 8461630 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8461630 - Flags: review?(ted) → review+
Blocks: 1043428, 1043433
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9b829e5002fe
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
No longer blocks: 1043433
You need to log in before you can comment on or make changes to this bug.