SDK's ui/toolbar element creates a border in Firefox 31

RESOLVED FIXED in Firefox 53

Status

Add-on SDK
General
RESOLVED FIXED
3 years ago
6 months ago

People

(Reporter: Christopher Plantijn, Assigned: Dylan Sharhon)

Tracking

unspecified
mozilla53
x86_64
Windows 7

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8461608 [details]
toolbar.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

Followed instructions on creating a toolbar via - https://developer.mozilla.org/en-US/Add-ons/SDK/Low-Level_APIs/ui_toolbar


Actual results:

The toolbar was created with a -moz-like  3d border around the edges. See Image included.


Expected results:

A clean ui toolbar that doesn't have the border.
Assignee: nobody → zer0
Component: Untriaged → General
Product: Firefox → Add-on SDK
Version: 31 Branch → unspecified

Updated

3 years ago
Priority: -- → P1

Updated

a year ago
Priority: P1 → --
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1325891
(Assignee)

Comment 2

6 months ago
Created attachment 8822124 [details] [diff] [review]
Add "border: 0" to existing toolbar style.

There are already no borders on Mac or Linux, just Windows. The original source of the border is

toolkit/themes/windows/global/toolbar.css:26-31
--------------------------------------------------------------------------------
...
toolbar {
  min-width: 1px;
  min-height: 19px;
  border-top: 1px solid ThreeDHighlight;
  border-bottom: 1px solid ThreeDShadow;
}
...
--------------------------------------------------------------------------------

but we can't change that because SeaMonkey (and Thunderbird?) still depend on that CSS property left over from the Firefox 3.x days.

However, addon toolbars are custom-styled in

addon-sdk/source/lib/sdk/ui/toolbar/view.js:99
--------------------------------------------------------------------------------
...
  view.setAttribute("style", "padding: 2px 0; max-height: 40px;");
...
--------------------------------------------------------------------------------

so it would be simplest to just add "border: 0;" to that line. :)
Attachment #8822124 - Flags: review?(zer0)
(Assignee)

Comment 3

6 months ago
Created attachment 8822292 [details] [diff] [review]
noborder2.patch

Correction: it's the inner "hack" toolbar that needs its border removed, not the outer toolbar.
Attachment #8822124 - Attachment is obsolete: true
Attachment #8822124 - Flags: review?(zer0)
Attachment #8822292 - Flags: review?(zer0)
Comment on attachment 8822292 [details] [diff] [review]
noborder2.patch

Looks good to me! Thanks for working on that.
Attachment #8822292 - Flags: review?(zer0) → review+
Assignee: zer0 → dylan
Keywords: checkin-needed
landed, thanks for contributing!

Comment 6

6 months ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7875d24ddb7a
Fix "SDK's ui/toolbar element creates a border in Firefox 31" r=zer0
Keywords: checkin-needed
(Assignee)

Comment 7

6 months ago
Awesome, thanks!

Comment 8

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7875d24ddb7a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.