Email reply sent to wrong recipients

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
5 years ago
9 months ago

People

(Reporter: galpeaceman, Unassigned)

Tracking

({privacy, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

I received an email from one of my clients, and clicked on the Reply button
I wrote the message and clicked "Send"


Actual results:

The email was sent to 12 random people from my address book.

Please note the following details:
a. The bug was reproduced 5 minutes later, when I tried to resent the response to the same sender. I saved the message, just to be sure, to the draft folder, made sure the recipient list only includes the sender, sent it, and again it was sent to the same 12 random people from my address book.
b. Some of my address book contains recipients with names in Hebrew, so this could be an agent in the problem
c. I am in charge of IT support for 50 thunderbird users, some of which have complained on similar issues. We all use Ubuntu, Thunderbird 31 (the latest, automatically updated version), and generally write in Hebrew

Attached is a zip of two files:
a. the original message I replied to
b. the message actually sent from the sent folder


Expected results:

The email should have been sent to the sender
Severity: normal → critical
I confirm that the bug consistently repeats itself on my computer, when replying to other messages of the same sender
Was this a problem in version 24?
Does it reproduce in safe mode?
 see https://support.mozilla.org/en-US/kb/safe-mode
Flags: needinfo?(galpeaceman)
Yes
I managed to reproduce the problem with another email address
Now I am sending an empty message, with the title "Test" to address "erez@rollout.io", and the problem repeats itself in safe-mode
I think that the common thing between the two is that both recipients do not appear in my address book
Also, their name appears in red in the TO line. But the red color also appears in messages that are sent to its destination
Flags: needinfo?(galpeaceman)
Regarding the version issue, I am not sure which version I had before, but it only appeared in version 31
Also, keep in mind (as I wrote earlier) that I am in contact with 50 other users who are having similar issues with this specific version
Whiteboard: [dupeme]
Some more info: in both cases recorded above, and in all repetition of both, the recipient list was not random, but the same list of recipients at all times. The list is not related in any way to the sender nor the new message. Its a group of 11 specific recipients I used to send messages to, maybe I used to have a list for them in my address book.
This could be a good lead to locate the problem, as a similar observation was made by one of my associates; she sent a message to two different sets of recipients, and in both times the message was actually sent to the same group of 9 people, she used to have a list for in her address book.
I experience the same issue. Although the recipient was just one person, (who is not in the address book) the message was sent to four random recipients from the address book. However, after deleting these four entries from the address book, Thunderbird refuses to send the message with a "No recipients specified (...)" dialog. Using Ubuntu 13.04 and Thunderbird 31 with Finnish locale (though the issue continues when I switch to US locale.) Needless to say that having sent a message full of commercial information to wrong persons caused me a lot of embarrassment.
This looks bad. But I couldn't reproduce on the attached email. When replying the recipient is in red font. Clicking Send later, the message source does only have the single recipient in the To: field.

But I am not sure the red color is intended, if it doesn't indicate some problem with autocomplete.
The red color should mean that autocomplete found no match for that text, for 31 it's sometimes wrong. There is bug 1042561 for that, but I wouldn't think its related...

I haven't been able to reproduce, but we also have bug 1008718, which mentions lists (likely this is dupe), so maybe that's somehow the key here.
Keywords: regression
Let's dupe this to bug 1008718.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008718
Reopening per reporter.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Hi,

Same problems on some computers here, since upgrade to TB 31.
"Reply to all", send mails to recipents that are not in the "To", "CC" or "CCi" list !
Some suppliers, received mails that were send to other suppliers ! This bug needs to be fixed quickly !!!
I'm going to re-install TB 24 on our computers.
Hi all,

I was able to reproduce something similar to this. The first time it appeared at 22nd December 2014. I just wrote an email and it was not sent to the selected address but to 5 random recipients from my address book. Since that time it happened time to time, but occasionally not always. For me the recipients were not really random, always the same 5 users received my mail instead of the real, entered recipients.

What I just realized today that I had a group in my address book with these 5 addresses inside and the group had no name. I will report back later to see if everything is back to normal as I just deleted the noname group.
How do you get a group with no name??
(In reply to Magnus Melin from comment #13)
> How do you get a group with no name??

Hmmm. Good question. I am no more able to create one without a name. I have already deleted the one I had.
Hello all.

Can you still reproduce this?
Flags: needinfo?(jmgigandet)
Flags: needinfo?(galpeaceman)
Flags: needinfo?(eunall)
Keywords: privacy
Summary: Emails sent to wrong recipients → Email reply sent to wrong recipients
No similar problems noticed for years.
For me it has been fixed a long time ago.
Flags: needinfo?(jmgigandet)
Thanks for the feedback.
Status: REOPENED → RESOLVED
Closed: 5 years ago9 months ago
Flags: needinfo?(galpeaceman)
Flags: needinfo?(eunall)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.