The last column of plug-ins page is too small for Japanese build

VERIFIED WONTFIX

Status

()

Core
Internationalization
P5
normal
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: Yuying Long, Assigned: Ying-Lin Xia)

Tracking

({l12y})

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This problem is splited from bug 93160.

In about plug-ins page, in most of tables, the last column is too narrow for
Japanese build, a Japanese word is broken down to vertical - see a followed
screen shot.
(Reporter)

Comment 1

17 years ago
See the attached image:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=44428
Keywords: l12y
QA Contact: andreasb → ylong
Summary: The last column of plu-ins page is too small for Japanese build → The last column of plug-ins page is too small for Japanese build

Comment 2

17 years ago
P5 Future.
Priority: -- → P5
Target Milestone: --- → Future

Comment 3

17 years ago
-> nhotta
I think you have solved this issue/or worked on the similar issue.
Assignee: yokoyama → nhotta

Comment 4

17 years ago
nhotta - what's the status of this bug fix? Is it something that can be easily
fixed soon so that's fixed in machv? thanks!

Comment 5

17 years ago
Let me investigate.
By the way, the Japanese translation for the third column title looks like done
by auto-translation, it does not really make sense.
Status: NEW → ASSIGNED
Target Milestone: Future → ---

Comment 6

17 years ago
Yuyin, could you attach HTML source of the localized about plugin page?
(Reporter)

Comment 7

17 years ago
Created attachment 57936 [details]
N6.2 JA about plugins page

Comment 8

17 years ago
The attachment showing fine on NS6.2.
(Reporter)

Comment 9

17 years ago
Ham, I checked it on both N6.2 JA and US build, I can see the problem on both of
them.

I guess the only difference between my machine and Naoki's is I have Java(full
installation) and he doesn't.(recommand?) 
(Assignee)

Comment 10

17 years ago
I think this is because the browser did put line-break at "/". If you enlarge 
the window, it should be fine.
(Reporter)

Comment 11

17 years ago
Looks like Ying's comments is right, but unfortunatity my monitor is not big
enough, so even I set it on maximal, the Java part still showing like the screen
shot that I attached.

Comment 12

17 years ago
Can this be taken care by l10n? Like change '/' to something else or edit the
style to change the ratio of the column widths?

Comment 13

17 years ago
Changing '/' doesn't solve the problem. We need to change the ratio of the 
column widths from 

  th.type, th.suff {
    width: 20%;
  }
  th.desc {
    width: 50%;

to 
  th.type, th.suff {
    width: 15%;
  }
  th.desc {
    width: 40%;

for Japanese.

Reassigned to yxia to have HTP fix in the future.
Assignee: nhotta → yxia
Status: ASSIGNED → NEW
(Assignee)

Comment 14

17 years ago
Bug moved to bugscape.
http://bugscape/show_bug.cgi?id=11049

WONTFIX this one since nothing to do here.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 15

17 years ago
Verified won't fix cuase we have a new bugscape bug for tacking this.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.