Closed Bug 1045498 Opened 7 years ago Closed 6 years ago

Link clicker UI needs new UX for notification of non supported browser on supported platform

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
2

Tracking

(firefox35 fixed, firefox36+ fixed, firefox37 fixed)

RESOLVED FIXED
mozilla37
Iteration:
37.1
Tracking Status
firefox35 --- fixed
firefox36 + fixed
firefox37 --- fixed
Blocking Flags:
backlog Fx36+

People

(Reporter: RT, Assigned: rgauthier)

References

()

Details

(Whiteboard: [strings][standalone])

User Story

As a link clicker using a non supported browser, I get prompted to use Firefox on a supported browser.

Use UX from https://people.mozilla.org/~dhenein/labs/loop-link-spec/#link-expired - only with the verbiage changes below....

Instead of "The URL is no longer available" use "Firefox Hello only works in browsers that support WebRTC"

Instead of "Download Firefox to make free audio and video calls!" use “Get Firefox and enjoy free audio and video conversations with friends”

Attachments

(2 files)

Implementation of new UX for non supported browsers on supported platforms.
Current experience: https://call.mozilla.com/#unsupportedBrowser
Darrin, could you please provide UX for this scenario?
Flags: needinfo?(dhenein)
Arcadio, do you have specific requirements for wording on this page given it is a chance to promote Firefox to non Firefox users?
Flags: needinfo?(alainez)
Probably the same as my comment here: https://bugzilla.mozilla.org/show_bug.cgi?id=1045495#c3
Flags: needinfo?(dhenein)
same comment as before.  can we make this a name change only - or at most - some better marketing wording - rather than a design UI change for Fx34.
Since this is link clicker side, I'm moving this to the Fx 35 cycle (sept 1 - oct 13)
Priority: P2 → P1
Target Milestone: mozilla34 → mozilla35
Whiteboard: [p=investigation by marketing]
Depends on: 1064173
(In reply to sescalante from comment #4)
> same comment as before.  can we make this a name change only - or at most -
> some better marketing wording - rather than a design UI change for Fx34.

I think the wording is fine (I believe it has been validated before) - see https://call.mozilla.com/#unsupportedBrowser (WebRTC! will be replaced at the appropriate time).

Arcadio, if you can confirm this text, then we could update the UX to match what Darrin suggests.
Points: --- → 2
Arcadio can you please let us know if you have views on wording there?
Same as Bug 1045495

Here are the lines. Let me know if these work and hopefully we already have these. 


"Firefox Hello only works in browsers that support WebRTC"
“Get Firefox and enjoy free audio and video conversations with friends”
Flags: needinfo?(alainez)
Thanks.
Blocks: 1082944
Marking this a a dependency of the UX meta as we now need UX for this.
We also need a button to download Firefox exposed on that page.
looking for strings - will try for Fx36 if we have them in time. (pre-11/20)
backlog: --- → Fx36?
Flags: needinfo?(alainez)
Whiteboard: [p=investigation by marketing] → [p=investigation by marketing][strings][standalone]
taking off priority until have missing info
Priority: P1 → --
Target Milestone: mozilla35 → ---
updated user story to reflect UX and wording
backlog: Fx36? → Fx36+
User Story: (updated)
Flags: needinfo?(alainez)
Whiteboard: [p=investigation by marketing][strings][standalone] → [strings][standalone]
Priority: -- → P2
No longer blocks: 1082944
same question as bug 1045495, though the user story wording is good to go here - but do we want a large Hello icon in the UX in addition to the Firefox icon?

We can always add later and OK this bug to go with the UX design now.  We need to get this in ASAP so we can land before 11/25 for strings.  so if we want a few weeks for a logo scaled up Hello design - we should go without.
Flags: needinfo?(alainez)
Priority: P2 → P1
From Arcadio via email in response to this bug:
Firefox will have more recognition than Firefox Hello or Hello logo. I default for the brand endorsement from Firefox so show only the Firefox logo. That seems cleaner, simpler, stronger.

OFFICIAL REQUEST: please never spell Firefox Hello like this: Firefox Hello!   

I believe it is the "!" (explanation point) that Arcadio doesn't want, but I am clarifying to be certain.
Flags: needinfo?(alainez)
+1 
Thank you Maire. 

Confirming that it is the exclamation point that should not be used in Firefox Hello
[Tracking Requested - why for this release]:
This patch is for the standalone app. We may choose to uplift it for the sake of shared code with desktop.  Marking this as tracking Fx36 so we get this fixed before Fx36 goes to Release.
Assignee: nobody → rgauthier
Attachment #8533172 - Flags: review?(standard8)
Attachment #8533172 - Flags: review?(nperriault)
Comment on attachment 8533172 [details] [diff] [review]
New Hello UX for non supported browsers

Review of attachment 8533172 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8533172 - Flags: review?(nperriault) → review+
Attachment #8533172 - Flags: review?(standard8)
https://hg.mozilla.org/mozilla-central/rev/d7bce9b4ab33
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I suspect this bug regressed the UI showcase, as it is now failing to render with the error:

TypeError: this.props.helper is undefined webapp.js:79:0
Comment on attachment 8533172 [details] [diff] [review]
New Hello UX for non supported browsers

Approval Request Comment
[Feature/regressing bug #]: N/A

[User impact if declined]: Possible merge conflicts

[Describe test coverage new/current, TBPL]: on m-c, really part of standalone

[Risks and why]: No risk as this is a standalone patch, NPOTB

[String/UUID change made/needed]: none (to the browser, change only to standalone which is separately translated).
Attachment #8533172 - Flags: approval-mozilla-beta?
Attachment #8533172 - Flags: approval-mozilla-aurora?
Attachment #8533935 - Flags: approval-mozilla-beta?
Attachment #8533935 - Flags: approval-mozilla-aurora?
Attachment #8533172 - Flags: approval-mozilla-beta?
Attachment #8533172 - Flags: approval-mozilla-beta+
Attachment #8533172 - Flags: approval-mozilla-aurora?
Attachment #8533172 - Flags: approval-mozilla-aurora+
Attachment #8533935 - Flags: approval-mozilla-beta?
Attachment #8533935 - Flags: approval-mozilla-beta+
Attachment #8533935 - Flags: approval-mozilla-aurora?
Attachment #8533935 - Flags: approval-mozilla-aurora+
Flags: qe-verify-
Depends on: 1097852
Blocks: 1122439
Depends on: 1045495
No longer depends on: 1045495
Duplicate of this bug: 1124100
You need to log in before you can comment on or make changes to this bug.