Intermittent failing test, Edges gesture > "before each" hook

RESOLVED FIXED in 2.1 S6 (10oct)

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: kgrandon, Assigned: etienne)

Tracking

({intermittent-failure})

unspecified
2.1 S6 (10oct)
x86
Mac OS X
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
kgrandon
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
1) Edges gesture > "before each" hook:

Error: timeout exceeded!

at Object.Client.waitForSync (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:682:16)

at Object.Client.waitFor (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:650:60)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/system/test/marionette/edges_gesture_test.js:46:12)

at callFn (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:223:21)

at Hook.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:216:7)

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:258:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:270:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:199:9

at Object.executeHook (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:369:18)

at process._tickCallback (node.js:415:13)
(Reporter)

Comment 1

4 years ago
Disabled on Travis in: https://github.com/mozilla-b2g/gaia/commit/689bec4562158447298d955822167d58ccf0244f
Keywords: intermittent-failure, leave-open
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1033427
(Assignee)

Comment 4

4 years ago
Created attachment 8493778 [details] [review]
Gaia PR

Got 100 consecutive run locally (on a tbpl-like setup where I could reproduce the intermittence). Will do more try-runs but this is ready for review.
Attachment #8493778 - Flags: review?(kgrandon)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8493778 [details] [review]
Gaia PR

Code seems fine to me semantically, though I feel like we may be masking the possibility of detecting reflows for a real client in the future.
Attachment #8493778 - Flags: review?(kgrandon) → review+
(Assignee)

Comment 6

4 years ago
(In reply to Kevin Grandon :kgrandon from comment #5)
> Comment on attachment 8493778 [details] [review]
> Gaia PR
> 
> Code seems fine to me semantically, though I feel like we may be masking the
> possibility of detecting reflows for a real client in the future.

Yes :/ Well only statusbar related.
Don't know how we'll be able to do reliable reflow testing on the statusbar (mainly because of the clock), but happy to cover the window manager in the meantime :)
Would it be possible to freeze the clock "à la" sinon fake timers?
(Assignee)

Comment 8

4 years ago
Comment on attachment 8493778 [details] [review]
Gaia PR

Ha! The test failed during the last try-run, back to the drawing board, clearing the r? flag.
Attachment #8493778 - Flags: review+
(Assignee)

Comment 9

4 years ago
Comment on attachment 8493778 [details] [review]
Gaia PR

Looks better, I've simplified the test to work with 2 apps instead of 3 (without losing coverage) in order to make the setup lighter.

The 60 try runs [1] look very good, wonder if I should trigger more.

[1] https://tbpl.mozilla.org/?rev=38777554289972bdee9308b3c8ea7dbb0bc1a3e1&tree=Gaia-Try
Attachment #8493778 - Flags: review?(kgrandon)
(Reporter)

Comment 10

4 years ago
Comment on attachment 8493778 [details] [review]
Gaia PR

Thanks for running this so many times. It does seem like we have quite a few intermittents (though many due to the socket connection problem). I unfortunately did see one failure related to this test here: https://tbpl.mozilla.org/php/getParsedLog.php?id=49039814&tree=Gaia-Try#error2

One option might be to split up these test cases into separate files. Then we could probably bring the left <-> right swiping tests back quickly. What do you think?
Attachment #8493778 - Flags: review?(kgrandon)
(Assignee)

Comment 11

4 years ago
Yes, enabling the vertical swipe test is a bit outside of the scope here. Just saw that the blocking bug mentioned in the comment was fixed so I turned it on :)

I'm giving it one shot (to keep it enabled) and if it fails I'll make a version of the patch with only the basic test.
(Assignee)

Comment 12

4 years ago
Created attachment 8498874 [details] [review]
New gaia PR
Attachment #8493778 - Attachment is obsolete: true
Attachment #8498874 - Flags: review?(kgrandon)
(Reporter)

Comment 13

4 years ago
Comment on attachment 8498874 [details] [review]
New gaia PR

Awesome. Let's see what this does. Thanks!
Attachment #8498874 - Flags: review?(kgrandon) → review+
(Reporter)

Comment 14

4 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/e7a5c7e6bf950992d8cf09e11a947b68d0dcb832
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
(Reporter)

Updated

4 years ago
Target Milestone: --- → 2.1 S6 (10oct)
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.