Closed Bug 1046090 Opened 5 years ago Closed 4 years ago

Explore if we can split Dialer and Contacts

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rik, Unassigned)

References

Details

(Whiteboard: [NG Gaia Contacts])

Attachments

(1 file)

Can we move Dialer and Contacts to separate apps while keeping the Contacts iframe inside Dialer?

This will help plan our 2.2 work.
:_)

Please let's do, let's do.

The only thing that contacts will require and sounds a bit weird is the telephony API to being able to call directly from the contact detail.

Apart from that, we are ready to go.
We have some asyncStorage that is also shared I believe.
Whiteboard: [planned-sprint c=]
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Other area to inspect: We share locale files between Dialer and Contacts.
Whiteboard: [planned-sprint c=] → [planned-sprint c=3]
Target Milestone: 2.1 S4 (12sep) → 2.1 S5 (26sep)
Just a loose prototype to move files and change paths. This will probably not land for a long time until the kinks of the script are ironed out. I just wanted to open up a pull request here illustrating what this simple script can do for us: https://github.com/KevinGrandon/gaia-split-communications

Not everything is functional yet, but we can iterate on things before or after the script is applied. My preference would be to basically be able to run this script and have everything working. Let me know what you think and if you have any concerns about this approach.
Depends on: 1064317
Depends on: 1064319
Target Milestone: 2.1 S5 (26sep) → 2.1 S6 (10oct)
Duplicate of this bug: 845945
Duplicate of this bug: 1013810
Assignee: nobody → anthony
Assignee: anthony → nobody
Target Milestone: 2.1 S6 (10oct) → 2.1 S7 (Oct24)
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
Assignee: nobody → drs.bugzilla
Whiteboard: [planned-sprint c=3] → [planned-sprint c=3][in-sprint=v2.1-S8]
Target Milestone: 2.1 S8 (7Nov) → 2.1 S9 (21Nov)
I'm descoping this from this sprint. We will be able to do a more accurate assessment once bug 1097757 is done, so I think that we should wait until then before coming back to this.
Depends on: dialer-tabless
Whiteboard: [planned-sprint c=3][in-sprint=v2.1-S8] → [planned-sprint c=3]
Target Milestone: 2.1 S9 (21Nov) → ---
Assignee: drs.bugzilla → nobody
Duplicate of this bug: 847417
Blocks: 1135340
Whiteboard: [planned-sprint c=3] → [NG Gaia Contacts]
Depends on: 1226229, 1226195
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.