Closed Bug 1046307 Opened 6 years ago Closed 4 years ago

Intermittent test_ThreadHangStats.js | test failed (with xpcshell return code: 0) | false == true

Categories

(Toolkit :: Telemetry, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Assigned: jchen)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Maybe a regression from bug 1034138?

https://tbpl.mozilla.org/php/getParsedLog.php?id=44903200&tree=Mozilla-Inbound

Android 4.0 Panda mozilla-inbound opt test xpcshell on 2014-07-30 09:16:30 PDT for push 569dda025a06
slave: panda-0167

09:42:12     INFO -  TEST-INFO | /builds/panda-0167/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_ThreadHangStats.js | running test ...
09:42:24  WARNING -  TEST-UNEXPECTED-FAIL | /builds/panda-0167/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_ThreadHangStats.js | test failed (with xpcshell return code: 0), see following log:
09:42:24     INFO -  >>>>>>>
09:42:24     INFO -  xpcw: cd /mnt/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit
09:42:24     INFO -  xpcw: xpcshell -r /mnt/sdcard/tests/xpcshell/c/httpd.manifest --greomni /data/local/xpcb/fennec-34.0a1.en-US.android-arm.apk -m -s -e const _HTTPD_JS_PATH = "/mnt/sdcard/tests/xpcshell/c/httpd.js"; -e const _HEAD_JS_PATH = "/mnt/sdcard/tests/xpcshell/head.js"; -e const _TESTING_MODULES_DIR = "/mnt/sdcard/tests/xpcshell/m"; -f /mnt/sdcard/tests/xpcshell/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/mnt/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js"]; -e const _TAIL_FILES = []; -e const _TEST_FILE = ["test_ThreadHangStats.js"]; -e _execute_test(); quit(0);
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test MAIN run_test pending (1)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test pending (2)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test pending (3)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test pending (4)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test MAIN run_test finished (4)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | running event loop
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test finished (3)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test finished (2)
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test pending (2)
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 80] "object" == "object"
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 69] "object" == "object"
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 70] 0 == 0
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 71] "number" == "number"
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 72] "number" == "number"
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 73] "number" == "number"
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 74] true == true
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 75] true == true
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results/check_histogram : 76] 33 == 33
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 83] true == true
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 84] 1 != 0
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 86] true == true
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 87] 1 != 0
09:42:24     INFO -  TEST-PASS | test_ThreadHangStats.js | [run_test/</check_results : 88] "string" == "string"
09:42:24  WARNING -  TEST-UNEXPECTED-FAIL | test_ThreadHangStats.js | false == true - See following stack:
09:42:24     INFO -  test_ThreadHangStats.js:run_test/</check_results:92
09:42:24     INFO -  test_ThreadHangStats.js:run_test/<:103
09:42:24     INFO -  /mnt/sdcard/tests/xpcshell/head.js:do_execute_soon/<.run:570
09:42:24     INFO -  /mnt/sdcard/tests/xpcshell/head.js:_do_main:191
09:42:24     INFO -  /mnt/sdcard/tests/xpcshell/head.js:_execute_test:405
09:42:24     INFO -  -e:null:1
09:42:24     INFO -  null:null:0
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
09:42:24     INFO -  TEST-INFO | (xpcshell/head.js) | test finished (2)
09:42:24     INFO -  System JS : WARNING test_ThreadHangStats.js:93 - reference to undefined property hang.nativeStack
09:42:24     INFO -  \x00
09:42:24     INFO -  <<<<<<<
Any thoughts on this Jim?
Flags: needinfo?(nchen)
It could be that, because there are many tests running, the hang monitor gets starved of CPU time and fails to kick in for the artificial hang in our test. If that's the case, xpcshell has an option to run the test by itself.

In the meantime, I'm borrowing an Android x86 test slave for another bug, and I can check to see if this bug shows up there. This test is disabled on Android x86 because of test failures so maybe it's related.
Depends on: 1051996
Flags: needinfo?(nchen)
To test the theory that the failure is due to high CPU load when running the test among other tests, this patch will run the test by itself. It can be backed out later if the failure still happens with this patch.
Attachment #8474687 - Flags: review?(vdjeric)
Comment on attachment 8474687 [details] [diff] [review]
Run test_ThreadHangStats.js sequentially (v1)

Review of attachment 8474687 [details] [diff] [review]:
-----------------------------------------------------------------

Hmm, why did you remove the 'skip-if = os == "android" && processor == "x86"' line?
Attachment #8474687 - Flags: review?(vdjeric) → review-
Flags: needinfo?(nchen)
Comment on attachment 8474687 [details] [diff] [review]
Run test_ThreadHangStats.js sequentially (v1)

Review of attachment 8474687 [details] [diff] [review]:
-----------------------------------------------------------------

16:06 <jchen> yes, the underlying bug was resolved. sorry i should have noted that :)
Attachment #8474687 - Flags: review- → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/bf759fde3847
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Keywords: leave-open
I don't think this is fixed :(
Flags: needinfo?(nchen)
(In reply to Vladan Djeric (:vladan) from comment #45)
> I don't think this is fixed :(

I'll request a panda loaner when I have some time.
Flags: needinfo?(nchen)
Vladan, can someone on your team please look at this?
Flags: needinfo?(vdjeric)
Jim, do you want take another crack at this intermittent test failure?
Flags: needinfo?(vdjeric) → needinfo?(nchen)
Haven't had this orange in a while.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(nchen)
Resolution: --- → WORKSFORME
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.