Find a solution for in page metrics tracking on interactive snippets

RESOLVED DUPLICATE of bug 1067324

Status

defect
RESOLVED DUPLICATE of bug 1067324
5 years ago
27 days ago

People

(Reporter: adam, Assigned: adam)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

5 years ago
Following on from Bug 1045106, and in relation to Bug 1045106.

We are testing interactive snippet experiences where Firefox users can engage with promotional content on the about:home page. For example, the Mozilla Webmaker team have produced a 'Hack the snippet' snippet, where users can click an initial message, then type color names to alter the page background. After this they are shown a link and invited to get involved in Webmaker.

Currently we do not track these on-page interactions at all. We will not know what % of people engage with this piece of interactive content.

* We do have impressions data for the snippet
* And we have impression data for the pages the snippet links to
* But the missing piece of info is the on page interaction. 

We do not need PII, just a way to appropriately collect total aggregate events.
Assignee

Comment 1

5 years ago
That was meant to be *in relation to Bug 1027377*

Also, I expect there will be many hoops involved here, and processes I don't know well, so could I request you CC any other people on this bug who you think can guide this, or would want to be involved/aware.

Updated

5 years ago
No longer depends on: 1045106
Ben: can you provide an overview of what was involved previously when we implemented snippet impressions on about:home when you led that project in bug 719090?
Flags: needinfo?(booboobenny+bugzilla)
Adam: for your reading pleasure:

bug 1003391

and 

https://groups.google.com/forum/#!searchin/mozilla.governance/analytics/mozilla.governance/UZO9U2MTTwM/DbO5Z5mN3DgJ

Not 100% related, but just food for thought if we try to tackle this one.
The wiki has a good summary of what we did under elevator pitch.

https://wiki.mozilla.org/Websites/Snippets/Impressions

If you want detailed implementation specs you can see this information here:

https://wiki.mozilla.org/Websites/Snippets/Impressions/Specs/URL_Parameters

https://wiki.mozilla.org/Websites/Snippets/Impressions/Specs/Metrics_Dashboard

If you have specific questions I can try to address them.
Flags: needinfo?(booboobenny+bugzilla)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1067324

Updated

27 days ago
Product: Snippets → Snippets Graveyard
You need to log in before you can comment on or make changes to this bug.