Closed Bug 1046505 Opened 8 years ago Closed 8 years ago

[Text Selection] Implement temporary shortcut for utility bubble.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mtseng, Assigned: mtseng)

References

Details

Attachments

(2 files, 1 obsolete file)

Quote from spec page 7 [1],
"If the user taps the edit field after copy or cut, the handle will pop up with the utility bubble which shows “paste” for further edit. This is a temporary shortcut and only appears after the action “copy/cut”. In this use case, the utility bubble will time-out after 3 secs if no action is taken. Once user taps “Paste”, the shortcut will not appear again by tapping edit field."

"If text is not pasted immediately after copy/cut, the text will be viewed as pasted after 15 seconds (count starting from the moment when there's no action at all), and there will be no paste shortcut pop up when tapping on edit field"

In other words, we must implement following features for this spec.
1. Tell embedder we are showing temporary shortcut or not based on copy/cut has been performed or not.
2. After copy/cut and there is no action for 15 seconds, disable temporary shortcut.

[1] https://bug921965.bugzilla.mozilla.org/attachment.cgi?id=8448605
Attached patch bug1046505 (obsolete) — Splinter Review
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
Attachment #8466004 - Flags: review?(ehsan)
Comment on attachment 8466004 [details] [diff] [review]
bug1046505

Review of attachment 8466004 [details] [diff] [review]:
-----------------------------------------------------------------

We shouldn't cripple the API like this, the code that uses the selectionchange event should be responsible for implementing this behavior.
Attachment #8466004 - Flags: review?(ehsan) → review-
Duplicate of this bug: 1020798
Attached patch bug1046505 v2Splinter Review
Once bug 1020802 is landed, we can move all temporary shortcut logic to gaia by applying this patch.
Attachment #8466004 - Attachment is obsolete: true
Depends on: 1020802
(In reply to Morris Tseng [:mtseng] from comment #4)
> Created attachment 8469027 [details] [diff] [review]
> bug1046505 v2
> 
> Once bug 1020802 is landed, we can move all temporary shortcut logic to gaia
> by applying this patch.

Great!
Comment on attachment 8475808 [details] [review]
PR to master

Hi Alive,
could you review this patch? 
Thanks.
Attachment #8475808 - Flags: review?(alive)
Attachment #8475808 - Flags: review?(alive) → review+
Thanks,
master: https://github.com/mozilla-b2g/gaia/commit/7e2165cbc81d32188a2a7cf0f4bac6a61c7f42fc
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.