Closed Bug 1023688 (CopyPasteLegacy) Opened 5 years ago Closed 4 years ago

[META] TouchCaret & SelectionCarets, and text selection/copy/paste support on B2G v2.2

Categories

(Core :: Selection, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: u459114, Unassigned)

References

Details

(Keywords: meta)

User Story

This is the meta bug for the legacy carets and copy & paste implementation on B2G branch v2.2. To make a feature request or bug report against B2G master, please make it depend on meta bug 1124074 which is for B2G branch v2.5 and above. Please see the wiki page for more information. https://wiki.mozilla.org/Copy_n_Paste

Attachments

(3 files, 2 obsolete files)

A META bug to trace status of text selection/copy/paste support on B2G
Depends on: 960897, 1019441
Depends on: 988143
Depends on: 1020261
Depends on: 1020798
Bug 987040 is the main function blocker at this moment
Alias: CopyPaste
4 main test case blockers.
Bug 1023087 - window manager copy/paste marionette test
Bug 987040  - copy/paste browser API mochitest
Bug 1019441 - selection caret marionette test
Bug 1020261 - touch caret marionette test

We need at least these 4 test cases landed to guarantee basic quality of this feature.
Depends on: 1024848
Attached file Text_Selection_Visual Spec.zip (obsolete) —
Hi Morris,
In order to make the selection caret easier to use, I revised the caret images.
Please help me update these images below:
text_caret_tilt_left.png
text_caret_tilt_left@1.5x.png
text_caret_tilt_left@2.25x.png
text_caret_tilt_left@2x.png
text_caret_tilt_right.png
text_caret_tilt_right@1.5x.png
text_caret_tilt_right@2.25x.png
text_caret_tilt_right@2x.png
text_caret.png
text_caret@1.5x.png
text_caret@2.25x.png
text_caret@2x.png

One other thing is that the hightlighting color looks different from the spec, please help me change it to #33b5e5, 40%. Thanks!
Let me know when you finish these adjustment so I can have a UI review :)
Flags: needinfo?(mtseng)
Hi George,
Text selection Visual spec revised: 
Please help adjust the utility menu's shadow.
Shadow: 2px 2px 5px 3px #3d3d3d
Let me know when you're done so I can see if the shadow looks good enough.

Thank you!:)
Flags: needinfo?(gduan)
Depends on: 1024930
Depends on: 1024933
OS: Gonk (Firefox OS) → Mac OS X
Hardware: All → x86
Depends on: 1024966
Flags: needinfo?(gduan)
Flags: needinfo?(mtseng)
What are the plans for the platform side of things here?  We've been working on text selection support on b2g for a while, so I'm aware of that piece, but I'm not sure what our plans are with regards to supporting clipboard for non-text-only content in the content process, etc.
Depends on: 1029943
We will work on non-editable content copy and paste after these two bugs land
Bug 987718 
Bug 987040

Rich text(non-text-only) copy-paste should be a thing after.
Depends on: 1035172
Depends on: 921965
Depends on: 1041436
Depends on: 1046732
Please check Bug 921965 to see the latest text selection Visual spec. thanks!!
Depends on: 1054889
Update text caret image assets(png)
Attachment #8439762 - Attachment is obsolete: true
Depends on: 1057256
Assignee: cku → nobody
Depends on: 1059061
Assignee: nobody → pchang
No longer depends on: 1035172
Depends on: 1049367
No longer depends on: 921965
Depends on: 1049380
Depends on: 1067255
Depends on: 1068042
Depends on: 1068461
Depends on: 1068475
Depends on: 1068474
Depends on: 1068525
Depends on: 1064799
Depends on: 1070843
Depends on: 1070851
Depends on: 1072769
Depends on: 1073457
Depends on: 1078991
Depends on: 1080465
Depends on: 1082413
Depends on: 1082425
Depends on: 1082486
Depends on: 1083009
No longer depends on: 1041436
Depends on: 1087193
Depends on: 1089553
Depends on: 1089979
Depends on: 1090008
No longer depends on: 1044736
Attaching OS-wide (core apps) text selection rules of thumb and UX guidelines.
Depends on: 1092425
Depends on: 1092427
Depends on: 1092430
Depends on: 1092437
Depends on: 1092440
Depends on: 1092441
Depends on: gaia-copy-paste
No longer depends on: 1092425
No longer depends on: 1092427
No longer depends on: 1092430
No longer depends on: 1092437
No longer depends on: 1092440
No longer depends on: 1092441
Depends on: 1094000
Depends on: 1094036
Depends on: 1094072
Depends on: 1097419
Update UX spec for 2.2.
Depends on: 1098161
(In reply to Omega Feng [:Omega] [:馮於懋] (please ni?) from comment #10)
> Created attachment 8521957 [details]
> FxOS 2.2 UX Spec_Text Selection_v1.3.pdf
> 
> Update UX spec for 2.2.

ni Morris, TY for checking the 2.2 UX spec
Flags: needinfo?(tlin)
Flags: needinfo?(mtseng)
Summarize differences between our implementation right now and ux spec.
Based on spec: https://bugzilla.mozilla.org/attachment.cgi?id=8521957

Page 6, Long press on empty area would select last word.
Page 7, Copy doesn’t hide carets and bubble.
Page 9, Long press on empty field would do nothing.
Page 10, Paste on password field shows unmask for seconds then mask.
Page 12, Right now we’re at “no ok” case.
Page 15, Keyboard always overlap carets.
Page 16, We’ll show “select all” button event if we select all content.
Page 26, Same as page 7, copy doesn’t hide carets and bubble.
Flags: needinfo?(mtseng)
> Page 7, Copy doesn’t hide carets and bubble.
What I saw is that after copying, carets does not hide, the bubble hides, and the selection does not collapse.
Flags: needinfo?(tlin)
(In reply to Ting-Yu Lin [:TYLin] (UTC+8) from comment #13)
> > Page 7, Copy doesn’t hide carets and bubble.
> What I saw is that after copying, carets does not hide, the bubble hides,
> and the selection does not collapse.
Ah, right. What I mean is carets doesn't hide and selection range remain un-change.
(In reply to Morris Tseng [:mtseng] from comment #12)
> Summarize differences between our implementation right now and ux spec.
> Based on spec: https://bugzilla.mozilla.org/attachment.cgi?id=8521957
> 
> Page 6, Long press on empty area would select last word.
> Page 7, Copy doesn’t hide carets and bubble.
> Page 9, Long press on empty field would do nothing.
Current the long tap will show the caret on input filed. With my WIP of bug 1068461, it could trigger the touch caert and text dialog.
> Page 10, Paste on password field shows unmask for seconds then mask.
> Page 12, Right now we’re at “no ok” case.
> Page 15, Keyboard always overlap carets.
> Page 16, We’ll show “select all” button event if we select all content.
> Page 26, Same as page 7, copy doesn’t hide carets and bubble.
No longer depends on: 1102135
QA Whiteboard: [2.2-feature-qa+][textselection]
QA Whiteboard: [2.2-feature-qa+][textselection] → [textselection]
Depends on: 1101364
Depends on: 1101376
QA Whiteboard: [textselection] → [textselection][2.2-feature-qa+]
Depends on: 1111433
Depends on: 1105547
Depends on: 1110917
Depends on: 1110963
Depends on: 1113502
Depends on: 1112473
Depends on: 1114409
Flags: in-moztrap?(gchang)
Depends on: 1114483
Depends on: 1090682
Depends on: 1114921
Depends on: 1114926
Depends on: 1114509
Depends on: 1115478
Depends on: 1117684
Depends on: 1118157
Depends on: 1119126
Depends on: 1119130
No longer depends on: 1118157
Depends on: 1119688
Depends on: 1120750
Depends on: 1120754
Depends on: 1120855
Depends on: 1121308
Depends on: 1121335
UX spec update
Password Input: Allow only "Select All" and "Paste" in password input
Attachment #8521957 - Attachment is obsolete: true
Depends on: 1121463
Depends on: 1121468
Depends on: 1123179
Depends on: 1120347
Depends on: 1123232
Depends on: 1120013
No longer depends on: 1121463
Depends on: 1124566
Depends on: 1124575
Depends on: 1125045
Depends on: 1125419
Depends on: 1126174
No longer depends on: 1113502
Depends on: 1122805
Depends on: 1126969
Depends on: 1127160
Depends on: 1126022
Depends on: 1117652
Depends on: 1120316
Depends on: 1127648
Depends on: 1127655
Depends on: 1127658
Depends on: 1127660
Depends on: 1127666
Depends on: 1127719
Depends on: 1127731
Depends on: 1127743
Depends on: 1127747
Depends on: 1127753
Depends on: 1127563
No longer depends on: 1067226
No longer depends on: 1120754
No longer depends on: 1082425
No longer depends on: 1021499
No longer depends on: 1115244
No longer depends on: 1118167
No longer depends on: 1089553
No longer depends on: 988143
No longer depends on: 1110039
No longer depends on: 1049380
Depends on: 1127954
Depends on: CopyPasteGaia
No longer depends on: 1119688
No longer depends on: 1120347
No longer depends on: 1126580
No longer depends on: 1127655
No longer depends on: 1127659
No longer depends on: 1127160
No longer depends on: 1114509
No longer depends on: 1127954
No longer depends on: 1127731
No longer depends on: 1127743
No longer depends on: 1127563
No longer depends on: 1127648
No longer depends on: 1127658
No longer depends on: 1127666
No longer depends on: 1105547
No longer depends on: 1124566
No longer depends on: 1125045
No longer depends on: 1126174
No longer depends on: 1127652
No longer depends on: 1126022
Depends on: 1127953
No longer depends on: 1117652
Duplicate of this bug: 924419
QA Whiteboard: [textselection][2.2-feature-qa+] → [COM=Text Selection][2.2-feature-qa+]
Depends on: 1130982
Depends on: 1130993
No longer depends on: 1130993
Depends on: 1125045
Depends on: 1124566
Depends on: 1131838
Test cases are here.
https://moztrap.mozilla.org/manage/cases/?filter-suite=836
Flags: in-moztrap?(gchang) → in-moztrap+
Depends on: 1132810
Depends on: 1135231
Depends on: 1135207
Depends on: 1136041
No longer depends on: 1068525
No longer depends on: 1125045
Depends on: 1139288
Depends on: 1140625
Depends on: 1142316
Depends on: 1127529
No longer depends on: 1123571
Depends on: 1144796
Depends on: 1021499
Depends on: 1149070
Depends on: 1152172
Is there developer documentation on the mechanism by which the "select all" mechanism operates?  In bug 1152172 it appears an unexpected common root is chosen for "select all" which is not what I would expect from the documentation at https://developer.mozilla.org/en-US/docs/Web/CSS/user-select.  (And I couldn't find any better sources in a cursory searching of MDN, and there appear to be no normative implementation references here other than the attached UX specs that don't address this situation.)
As a follow-up, I've started a thread on dev.gaia about whether the current "select all" implementation should operate as it does since I was surprised that it really tries to select everything: https://groups.google.com/forum/#!topic/mozilla.dev.gaia/3tBQxCN5INQ
Depends on: 1154686
No longer depends on: 1154686
Depends on: 1155106
No longer depends on: 1155106
Depends on: 1160299
No longer depends on: 1160299
No longer depends on: 1132810
No longer depends on: 1121468
No longer depends on: 1131838
No longer depends on: 1142316
Depends on: 1221459
Depends on: 1221462
Depends on: 1225701
Depends on: 1228706
Alias: CopyPaste → CopyPasteLegacy
Assignee: howareyou322 → nobody
Summary: [META] Text selection/copy/paste support on B2G → [META] TouchCaret & SelectionCarets, and text selection/copy/paste support on B2G v2.2
User Story: (updated)
User Story: (updated)
No longer depends on: 1228706
Depends on: 1234118
The touch/selection carets in gecko, related event handling in browser-element, and text_selection_dialog.js in Gaia had been removed. This old meta bug is now officially retired, and the new meta bug is Bug 1124074. Thank you all for helping.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Depends on: 1301325
Depends on: 1152432
You need to log in before you can comment on or make changes to this bug.