Update Firefox Accounts/Firefox Sync integration to use the WebChannel abstraction

RESOLVED DUPLICATE of bug 1146904

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1146904
3 years ago
3 years ago

People

(Reporter: ckarlof, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
WebChannels are a way for chrome code to communicate with unprivileged web content (bug 1022064). We could modify about:accounts to use this or have the Firefox Accounts code in gecko use a WebChannel to communicate directly with a accounts.firefox.com page. Related: bug 998051 (Re-architect the FxA Sync login to load directly in a tab, not in an iframe in about:accounts)
Blocks: 998051
Flags: firefox-backlog+
See Also: → bug 1143692
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146904
You need to log in before you can comment on or make changes to this bug.