Last Comment Bug 1047127 - Panning very stuttery on this page with overflow-x
: Panning very stuttery on this page with overflow-x
Status: RESOLVED FIXED
: testcase
Product: Firefox for Android
Classification: Client Software
Component: Graphics, Panning and Zooming (show other bugs)
: Trunk
: ARM Android
-- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Kartikaya Gupta (email:kats@mozilla.com)
Mentors:
http://people.mozilla.org/~mwargers/t...
: 1125048 (view as bug list)
Depends on: fennec-aboard-apz
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-31 17:01 PDT by Martijn Wargers [:mwargers]
Modified: 2016-07-29 14:41 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
48+


Attachments

Description User image Martijn Wargers [:mwargers] 2014-07-31 17:01:44 PDT
See url test page, when trying to pan on that page, the page scrolls rather slowly and stuttery.
In Chrome on Android, the scrolling is smooth.
Comment 1 User image Aaron Train [:aaronmt] 2014-08-02 10:25:21 PDT
Profile: http://people.mozilla.org/~atrain/misc/bug1047127.dms
Comment 2 User image Kartikaya Gupta (email:kats@mozilla.com) 2014-08-05 20:02:47 PDT
Thanks for the profile, it confirms my suspicion that the stutter is from synchronous painting and that async subframe scrolling should fix it.
Comment 3 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2015-03-04 09:41:03 PST
*** Bug 1125048 has been marked as a duplicate of this bug. ***
Comment 4 User image Richard Newman [:rnewman] 2015-05-14 10:21:12 PDT
APZ -> Nightly+
Comment 5 User image Kartikaya Gupta (email:kats@mozilla.com) 2015-06-10 11:43:44 PDT
Nothing to do here until we get APZ working on fennec.
Comment 6 User image Kartikaya Gupta (email:kats@mozilla.com) 2015-12-01 13:34:21 PST
This works well with APZ on nightly. Making this depend on the bug that tracks shipping APZ on fennec.

Note You need to log in before you can comment on or make changes to this bug.